1. #1

    Deleting Railroads is leaving behind a blocking graphic.



    i have noticed this recently and will accept it if i am told it is because i have installed mods, but i am unsure the mods are the problem because it is the first time i have deleted railtracks since installing them.
    i am left with a small circular graphic where railtracks cross roads and if i don't notice and delete them, they cause a problem later with building. also there are 'invisible' things which block 1x1 squares and when i cover the surrounding squares with a road, to find the square in question, an 'end of the line' railtrack appears, but is invisible until i surround it with roads.
    anyone else? (would like to rule out the mod being the culprit)
    thanks.
    Share this post

  2. #2
    Ubi-Milky's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    1,674
    Hello P0PPYTAT, thanks for getting in touch with us about this railroad bug.

    Usually with any issues in the game we will ask the player if they are running mods first, then ask the play to uninstall them before updating the game.

    Can you please uninstall the mods you are using temporarily, start a new campaign, then see if this issue with the railroads exists when not running the game with mods to be sure if this is a bug with the game? Thank you, please let us know when you can.
     1 people found this helpful
    Share this post

  3. #3
    oh maaan...you focused on the Mods lol
    no worries...if i must start a new game just for you, i will...but only because i like you lol
    Share this post

  4. #4
    Ubi-Milky's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    1,674
    Ahwww schucks
    Apologies P0PPYTAT, it has to be done! I know a lot of players like to use mods in the games but we have to be sure if its the base game affected or a behaviour caused by mods to be sure.To quote the Anno teams sticky post -

    If you install mods then you are changing the official game files, keep in mind that we won’t be able to provide any official technical support for your game. Changing the files of your game can create bugs, cause instability of the game client or even damage your save file. This means that if anything goes wrong after applying a mod (like black screens or game crashes) the Ubisoft support team will not be able to help you until you reset all the changes.
    By all means if you start a new campaign and this issue still occurs please come back and let us know in the thread and one of us will happily report this to the team! If you can try to link us to a video as it often makes it easier to see the bug occuring in real time then a screenshot, if you wouldn't mind
    Share this post

  5. #5

    already had one fire and the AI's have taken all the good islands.
    Pfff...my liking of you is decreasing LOL
    Share this post

  6. #6
    Poppy ... that is a mod issue. I have it also. The graphic cover broke in the last big update... err update 9?

    I haven't looked into it... but it is either between the train station mod or spice it up. I think that crossing cover was spice it up. I'll look into it later.

    The easy fix, to make the trains still work, is to only have the train track cross on a dirt road. The conflict is worse with the stone roads (worker roads). You can run stone up to both sides of the crossing... but make sure you only use dirt at the actual crossing.

    If you get the bug where you try to delete the road (at crossing) and can't rebuild the track over that section... use your delete tool twice on the section where the crossing is. There is a hidden (incorrect) item there that is invisible. That item (I believe) is the old mod cover that is now invisible and de-franchised since the latest update.

    This is not a great shot to show the cover... but look at where the train crosses. That is the old mod crossing cover that is now broke. It use to say 'railway crossing' on it

    https://i.imgur.com/NiAzzcu.jpg


    I'll look into it later. I need to fix this for my game too. The rails do work... even if they look strange right now... but yeah, make the crossings on dirt only for now.
    Share this post

  7. #7
    actually... since looking at your screenshot... I bet what may have happened is that the old cover is using the same db number as one of the new worker 'warehouse' pieces they added recently.

    In the set that has stuff like the little water tower and barrels. I don't get that round piece you are showing... but I do get a conflict.

    I'll look later when I'm more awake / alert.
    Share this post

  8. #8
    I just started looking around PoppyTat... it is in the City_Ornaments_MU mod of Spice it Up... mod folder. I can confirm that City_Ornaments_MU is at least a good part of it by testing a save with-out the mod running.

    I also have just found this https://www.reddit.com/r/anno/commen..._graphics_bug/ Let me look around a bit more and test what they have written on that post.

    I'm gonna have to fix this because taking out City_Ornaments_MU would destroy my main save's errrr beauty?!!
    Share this post

  9. #9


    LOL
    thankyou so much for checking for me
    i just got told to turn my machine off because i've been playing 12 hours <sigh>...just to find out if this little 1x1 graphic was mod based, i was hoping it wasn't lol...not quite got to engineers yet so haven't managed to check 100% but, i will take your word for it...besides, i am dying to get back to my proper game, this has been a looooong day, glad i had nothing else planned LOL

    if anything i now have a game which i can check for mod errors.

    thanks again
     1 people found this helpful
    Share this post

  10. #10
    Deleting that section of code (that was suggested in the reddit post) did bring back the worker road crossings for me... kind of. It's working well enough that I am happy with it... until maybe I find out more.

    There is still some unexpected behavior. I don't know if the problem is in the save file, on my established game, or if there is another conflict I haven't found yet.

    This is what is working for me (after deleting the code section in City_Ornaments_MU assets xml). Build the area you want a crossing in dirt... where the crossing will take place. When the track goes over the road, at crossing, the dirt section will turn to worker road stone. Then just add stone to the rest of the road section to make it all match Sadly, the modded roads turn to worker stone at crossing.

    but then that's what we get for running mods :P We get to play with extra stuff but increase our frustrations If you need more help just hit me up on chat pm. I'll try to keep an eye out on this thread even though I'm almost always just in the general section only.


    worker crossings are back \ /
    https://i.imgur.com/48K2LEI.jpg
    Share this post

  11. #11
    i removed the part of code, reinstalled the mods and started my original game...the graphic is still there after removing rail or road so that fix didn't work for me...

    i found it clears completely with a single click to it, rather than clearing a stretch of road/rail which is when the graphic is left behind...so i just need to remember to start the deleting with the 'crossroads' first or go back and check (which is only a problem with a crash and my memory loss of what i was doing previous to the crash lol)
    the rails do kinda look out of place at crossroads now...dirt road doesn't quite cut it for me...

    i am still going to check this against my new game...i got that far, wasted half a day... i have to see it through LOL
    Share this post

  12. #12
    love your screen shots...they give me so many ideas, i just wish i held out building my main island til i got Sunken Treasures, thats gonna be a lot of work moving all my houses and stuff...so i guess my new game will eventually come in handy as a 'redo' (like a second child LOL)
     1 people found this helpful
    Share this post