1. #21
    Don't disconnect from Ubisoft connect. It corrupts your save file if you do.
    Just tested it.
     1 people found this helpful
    Share this post

  2. #22
    I get the same error about lacking privileges or some such permissions when trying to reply as well.

    If you look at the "Recent Posts" page, all of the most recent ones are from Ubisoft people, and the most recent one was from 11/21 at about 10:30 AM Central Time. So something is certainly wrong over there.

    The Beta testing seems to not be going well I guess. They should revert back to these forums.
     1 people found this helpful
    Share this post

  3. #23
    Originally Posted by MissM16 Go to original post
    Same.

    I think we all got locked out so Ubi staff can catch up collecting info and replying to the plethora of bug report posts : /
    Yeah and with all the bugs glitches etc. it would take them at least a month to finally catch up.

    Btw. when i woke up this morning i did not expect this many replies already.
     1 people found this helpful
    Share this post

  4. #24
    Roxxai's Avatar Junior Member
    Join Date
    Aug 2019
    Posts
    10
    seems iam not the only one that cant create new topics on the valhalla forums so i shall ask my question here


    anyone know how to find the big sturgeons? iam trying to complete the fishing hut challenges, all the fishing info says that sturgeons can be found in the rivers and seas of cent, i've spent 2 hours going up and down all the rivers in cent and i've only been able to find regular sturgeons not any big sturgeons, i've also searched the seas near cent far and wide for a good 30 minutes to an hour and havent seen a single fish out there
    Share this post

  5. #25
    Originally Posted by Dbjs2009 Go to original post
    Same thing here, I'm unable to reply their on a thread to report bugs, it seems like the forum is just as bad as their products, buggy and broken!
    Yes the bugs i'm already back to my PS4 because i was not able to play the game properly on my PS5. And yesterday evening i stopped playing altogether because there was a gamebraking bug. And i was not able to let them know that i had that gbbug.

    So i'm done with Valhalla at the moment it's as you said a "buggy and broken" game.
    Share this post

  6. #26
    Originally Posted by longjohn119 Go to original post
    The problem with the new forum is it is such a mess that when you do find an interesting conversation it gets lost in the mix and you can't find it again ...... As far as I'm concerned the only real problem with these old forums was poor spam filtering at times .....The new one looks like a Steam forum only worse .....
    Yes i also had that a couple of times an example i was there as a visitor and i saw an interesting thread i went online to post a reply ( when that was still possible ) but the thread was gone and i could not find it anywhere it also got lost in the mix.
    Share this post

  7. #27
    Update i at least can reply in the Valhalla forum again i hope that you guys can do the same.
     2 people found this helpful
    Share this post

  8. #28
    bitebug2003's Avatar Global Moderator
    Join Date
    Jul 2003
    Posts
    6,191
    Yes I just posted there

    Thanks for letting us know
     1 people found this helpful
    Share this post

  9. #29
    Originally Posted by longjohn119 Go to original post
    I would hope so I've been waiting a full week for a reply ..... They wanted a video so I posted one and then they wanted timestamps and it took a couple of days and I posted the time stamps ..... and haven't heard back from them since even after replying to the thread a couple of more times .....

    Sometimes I think the only reason they ask for videos and then time stamps is to sluff us off .......

    I'm still of a mind that whatever they added to the game to hook it to the new Ubisoft Connect is what is causing most of the problems and that's why they didn't catch them in testing because they did most of the testing before hooking it ..... If you look at the bug list they put up 80% of the bugs start with "unable to complete such and such quest" ...... That's not 10 or 15 bugs it is one bug affecting everything .... possibly even ties back to registering the Challenges as completed in Ubisoft Connect ...... It's still broke in Odyssey too and we can't access our rewards anymore ...... There are definitely some serious issues with it and the AC game engine playing nice together
    Yes... I saw you posting about the Aim Assist being broken. The bow is just as useless as the bird for me without it. Ughhh

    I figured that was the case for most bugs so I started a new game completely offline. It fixed some of the bugs (like actually showing me male Eivor who I picked from the start in the load screen instead of the child and finally getting rid of the photos on my map) but playing offline didn't fix game breaking bugs unfortunately.

    On my second offline new game, there was a quest which I finished but I couldn't talk to the NPC quest giver to complete the quest because he got stuck on a chair. He had one foot on a chair and his other foot was spazzing out on and off the chair. I tried everything to push him off the chair (including traveling out and restarting) so I can talk to him and nothing worked. He was stuck and I couldn't continue. I saw countless threads of NPC quest givers getting stuck, missing, being dead, not walking when you're supposed to follow them, ignoring you and not talking etc.

    So that's when I quit playing altogether. I'll pick it back up when they fix this broken mess.
    Share this post

  10. #30
    Originally Posted by AnimusLover Go to original post
    That's probably exactly it.
    I don't envy the mods right now, having to be on the front lines of an incompetent company who expects us to pay full price to be beta testers for their turd of a game.
    That's exactly how I feel. We paid them to be beta testers. -.-

    I completely stopped playing for now. This is the first AC game I bought at launch (I usually get them a couple of months after release) so since AC1 I remained blissfully unaware of all launch bugs... until now, that is.
    Share this post