1. #1

    Archaeological expedition bug?

    I have an issue with an archaeological expedition. At some point in one of the incidents where you have to make a choice. All i get a map but there is nothing or anywhere i can click anything. All i can do is click X to go back.
    I really like to get this fixed since the ship i use is that really big one you get from a long quest line and only have 1 of.

    https://i.imgur.com/xaaL8Oi.jpg
    Share this post

  2. #2
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019
    Posts
    3,709
    Originally Posted by C0elbyte Go to original post
    I have an issue with an archaeological expedition. At some point in one of the incidents where you have to make a choice. All i get a map but there is nothing or anywhere i can click anything. All i can do is click X to go back.
    I really like to get this fixed since the ship i use is that really big one you get from a long quest line and only have 1 of.

    https://i.imgur.com/xaaL8Oi.jpg
    Hello! Does this only seem to happen with Land of Lions expeditions?

    Our team is aware of this and they are currently working on a fix. Not to worry, this should be behind us very soon!
    Share this post

  3. #3
    Ok thank you. Cant wait for patch
    Share this post

  4. #4
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019
    Posts
    3,709
    Originally Posted by C0elbyte Go to original post
    Ok thank you. Cant wait for patch
    Any time at all I have heard this issue is planned to be fixed with Update 9.1, which is tomorrow.

    Enjoy your day!
    Share this post