1. #281
    I am really sad on this issue. The workaround didn't work for me, made it two times.
    Share this post

  2. #282
    I need to update this and it fixed actually.
    Be sure you get Green Connection on in game, when i tried for the first time, even with connection on, the game for some reason got no connection, and then when i tried for second time, it did not work. Now I removed the uplay again, and restart the pc and tried for the third time, and it worked.
    Share this post

  3. #283
    not worked for me I'm sad lol
    Share this post

  4. #284
    Ubi-TheBerry's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    2,165
    Hey there guys!

    For those of you still unable to access some Club / Connect Rewards, sorry for the inconvenience!

    This has been under investigation with the team, so reset assured work is ongoing to resolve this

    We'll keep the forums updated as and when we receive further information regarding this or any dates to expect a fix

    Thank you for your patience!
    Share this post

  5. #285
    Ubi-TheBerry's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    2,165
    Hey there guys!

    For those of you still unable to access some Club / Connect Rewards, sorry for the inconvenience!

    This has been under investigation with the team, so reset assured work is ongoing to resolve this

    We'll keep the forums updated as and when we receive further information regarding this or any dates to expect a fix

    Thank you for your patience!
     2 people found this helpful
    Share this post

  6. #286
    Thank you first of all, it worked just fine for me. The only problem now is every time i start the game it says "Failed to synchronize achievements". Is that anything to worry about ? My Save Games are all just fine
    Share this post

  7. #287
    Am having this same issue. All the Rewards are unlocked in Uplay/UbiConnect, but in-game there not, and totally unusable.
    Share this post

  8. #288
    Same for me, i've just buy the complete edition and all dlc portraits/ornaments are locked.
    Share this post

  9. #289
    Hello, I bought the full version of the game and unlocked all the rewards in the store, but did not activate. Enter the game. Please help me.
    Share this post

  10. #290
    https://forums.ubisoft.com/showthrea...4#post15287714

    Guys use this workaround to get the rewards back!
    This works for me!
    Share this post

  11. #291
    Read my reply, hope this helps u! https://forums.ubisoft.com/showthrea...4#post15287714
     1 people found this helpful
    Share this post

  12. #292
    Thank u sir, u are a god send, i been waiting for this to get fixed since all the rewards for my other games have arrived back, Question tho, can i uninstall the old uplay or just delete it and leave it installed?
    Share this post

  13. #293
    @Karmidzhanov

    Thx a lot man, it really works for me. Pretty good that u share it with the community. Greetings from Germany
    Share this post

  14. #294

    Thank you. It works.

    The fact that you found a solution when Ubisoft didn't even try. instead made excuses in a thread about the issue (from that thread I got to this one), shows what incompetent people work there and how little the company cares about the users.

    Thank you for finding how to get the rewards and helping a lot of people.
    Share this post

  15. #295

    Thank You

    Mate you, my friend are a bloody legend, I know you said you did not find the fix but thanks to you, I and many others have been able to fix the issue, so thank you once again and have yourself a good rest of your life.
    Share this post

  16. #296
    This solution worked for me. Much appreciated! Ubisoft in the worst developer in the world, and ill never purchase again an Ubisoft game.
    Share this post

  17. #297
    Thank you so much! Worked well, super detailed description!
    Share this post

  18. #298

    It solved my problems

    Thanks a lot friend, it solved my problems too.
    Cheers!
    Share this post

  19. #299

    i have the same problem

    i have bought the deluxe edition and cannot access the rewards from all the dlcs can i have some help???????? please its annoying how it says I've unlocked them and it wont let me access
    Share this post

  20. #300
    Ubi-Thorlof's Avatar Anno Community Developer
    Join Date
    Apr 2018
    Posts
    643
    We're currently working on a fix for this issue that will be included in the next Game Update (9.3). More info on this soon
    Share this post

  21. #301
    And?
    Share this post

  22. #302
    I'm having this same issue. I cannot use portraits or banners/ flags that come with dlc that i have purchased and installed. My ubisoft account is Maplemusketeer.

    my dlc are: A day at the amusements, Botannica, Bright Harvest, seat of power, the passage and the imperial pack.

    Can the devs please manually redeem these for me, as I have already tried verifying files, and re-installing the game and neitherof those worked.

    Thanks.
    Share this post

  23. #303
    Originally Posted by BLURRRR_89 Go to original post
    Thanks for fixing Ubisoft's mistake. You were more helpful than the company and the CS reps.
    Share this post

  24. #304

    Dlc & rewards not working!!

    I have rewards unlocked & dlc bought in ubisoft connect but not in the game
    how do i unlock the rewards & dlc?
    Share this post

  25. #305
    Ubi-TheBerry's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    2,165
    Hey there guys,

    daqoos7ar, I've merged your thread here as it relates to the same issue.

    We've been aware of issues with redeeming Ubisoft Connect content since the migration from the Club last October.

    However we have received news a fix is aimed to be released in Patch 9.3

    Please keep an eye on https://www.anno-union.com/en for updates and patch notes regarding this update when it becomes available

    Thank you for your continued patience and sorry for the inconvenience!
    Share this post

  26. #306
    Hi guys i Have the same issue with rewards coud you please unlock for me the anno 1800 rewards in game also. Thanks <3
    Share this post

  27. #307
    Pls Ubisoft fix this soon.

    Still cant use the club rewards....

    Edit* Update next tuesday will fix this
    Share this post

  28. #308

    Works like a charm!

    Thanks for this. Sadly Ubi ignored this for a year now but hey! it's the community who got its back
    go here to fix it
    https://forums.ubisoft.com/showthrea...4#post15287714
    Share this post

  29. #309
    I just lost access to the club rewards in the last week. Could have been the patch or me buying the 2 dlc I was missing (christmas and carneval).

    currently looks like this: all ornaments are locked and if selected redirect to the 'Rewards' overlay, which says all reward claimed


    Unfortunatly the fixed proposed in this thread did not help. Neither did a reinstall of Ubisoft Connect and the game.
    Share this post

  30. #310
    Ubi-Thorlof's Avatar Anno Community Developer
    Join Date
    Apr 2018
    Posts
    643
    Hey, for the issue of the ornaments being locked in-game:
    Could you please try verifying the game files (https://support.ubisoft.com/en-GB/Ar...ct-Desktop-App) followed by a restart of Ubisoft Connect.

    This should unlock the ornaments in-game.
    Share this post

  31. #311
    Originally Posted by Ubi-Thorlof Go to original post
    Hey, for the issue of the ornaments being locked in-game:
    Could you please try verifying the game files (https://support.ubisoft.com/en-GB/Ar...ct-Desktop-App) followed by a restart of Ubisoft Connect.

    This should unlock the ornaments in-game.
    I don't have the option to verify game files in Ubisoft Connect, as I got the game on Steam.



    Verifying the files in Steam and restarting Ubisoft Connect did not fix the problem.

    Also uninstalling and reinstalling the game as well as Ubisoft Connect did not work.
    Share this post

  32. #312
    So I got the club ornaments back after deleting the save folder '%USERPROFILE%/Documents/Anno 1800'.
    (I also unchecked 'Enable cloud save synchronization for supported games' in Ubisoft Connect. Not sure if that affected anything, since all my saves got restored anyway.)

    But now I don't have access to multiplayer anymore now.



    Maybe the service is down right now? Will see if that is different tomorrow.
    Share this post

  33. #313
    Club ornaments and multiplayer working as of today.
    Share this post

  34. #314
    I still can't access the club rewards in my game, and I can't verify game files since I don't play the game locally; I use a streaming service (GeForce NOW specifically). I would really appreciate some assistance
    Share this post

  35. #315
    I've tried the workaround twice, with no luck. It seems to be the only workaround. Has anyone tried something else?
    Glad I ran into this issue so I know to avoid buying from Ubisoft in the future.
    Share this post

  36. #316
    @stealtheart
    Updating to the latest Anno patch should solve the problem with Anno 1800 (not with all the other games that have this issue but only with Anno 1800).
    You could try to verify your game files or reinstall the game to make sure your Anno 1800 is up to date and everything is working.

    @SSSoto
    GeforceNow and other streaming services are, as far as i know, not officially supported by the Anno devs. It can work but if its not working, you are on your own. Like mac support or Anno 1800 on Linux. There seem to be more problems with GeforceNow and Anno 1800 but also generally with GeforceNow and all kinds of games. From what i read online, GeforceNow seems to me more like a beta than anything really reliably usable. Instead of verifying files, you can completely reinstall Anno 1800 and see if it works.
    I would also try to install Anno 1800 locally on your maschine and see if the problem persists.
    Share this post

  37. #317
    Originally Posted by chris02918 Go to original post
    @stealtheart
    Updating to the latest Anno patch should solve the problem with Anno 1800 (not with all the other games that have this issue but only with Anno 1800).
    You could try to verify your game files or reinstall the game to make sure your Anno 1800 is up to date and everything is working.

    @SSSoto
    GeforceNow and other streaming services are, as far as i know, not officially supported by the Anno devs. It can work but if its not working, you are on your own. Like mac support or Anno 1800 on Linux. There seem to be more problems with GeforceNow and Anno 1800 but also generally with GeforceNow and all kinds of games. From what i read online, GeforceNow seems to me more like a beta than anything really reliably usable. Instead of verifying files, you can completely reinstall Anno 1800 and see if it works.
    I would also try to install Anno 1800 locally on your maschine and see if the problem persists.
    Tried verifying twice and restarting a few times and no go. I want to avoid reinstalling because my internet is dreadfully slow, took over 12 hours to download it yesterday. But thanks for trying.
    Share this post

  38. #318
    @stealtheart
    Have you tried deleting your accountdatafile/s in ubi connect and restarting ubi connect after verifying files and before starting the game again?
    This seems to help some people.
    Share this post

  39. #319
    Thanks for your reply, but that's not very helpful since the entire reason I'm playing it through a streaming service is because my own PC doesn't have the processing power to handle a game like Anno. I find it strange that the devs wouldn't support the game played through a streaming service since they are making it available on that platform; if they don't intend to assist their customers who purchased their game with the expectation they would be able to play it through that platform that's just poor customer service. I mean, if I'm on my own I really should be just getting a refund for all the content I can't use. I'm very disappointed I still haven't heard from a dev about this.
    Share this post

  40. #320
    @SSSoto
    You could try contacting the support with your problem. Ubi support and GeforceNow support. The problem is, in my opinion, something GefoceNow must fix and not then Anno devs.
    Not alot of devs even actively work with GeforceNow. Nvidia just lets everything run on their servers and expect people to cry enough that devs pour work and money into it to fix Nvidias bugs or limitations. GeforceNow is not a normal Windows PC. Its something different, like Linux. Its not on the Anno team to fix stuff they don't support.
    For me this problem clearly lies with Nvidia and not with Anno. Its the same with every other not supported platform. It can run but it needn't. And if it does not run, you or your platform must fix it.
    Your ranting here is like me ranting if a new patch prevents Anno to run on my Linux machine and asking for a refund. Everybody here would just say wtf run it on windows instead of Linux and be done with it. Linux is not supported etc. And the same goes with you and your GeforceNow as far as i know. I know its a bummer. I am a Linux lover and would love to see my favorite plattform supported but i have to be realistic and accept the situation. Its not supported, if something goes wrong i cannot expect help, i have to fix it myself or ask the community or devs around my platform etc etc.
    Share this post