1. #1
    SCDA will just not start, I,m running it in compatability mode for Win xp, My system (Win 7 64bit} passes the compatability test with flying colours, I have installed all the latest Patches, but it stil refuses to start.
    Share this post

  2. #2
    negadave's Avatar Ubisoft Support Staff NCSA
    Join Date
    Jan 2010
    Posts
    190
    Are you getting any error messages at launch?
    I suggest you contact Tech Support so we can troubleshoot your issue.
    Since the game predates Win 7, there may be some incompatibilities, even if you are using compatibility mode for XP.

    http://www.ubi.com/US/Support/...nationalSupport.aspx
    Share this post

  3. #3
    Originally posted by brogs60:
    SCDA will just not start, I,m running it in compatability mode for Win xp, My system (Win 7 64bit} passes the compatability test with flying colours, I have installed all the latest Patches, but it stil refuses to start.
    First make sure you update and patch the Game fully, before doing anything. Apply both version 1.01 and 1.02 patches. These patches are for the US version of the game only, but if you have a non-US version, then you can run the SC4UpdateLauncher.exe found in C:\Program Files\Ubisoft\Tom Clancy's Splinter Cell Double Agent\support\UpdateLauncher.

    Start the game by double-clicking on the SCDA Desktop icon. Do 'not' use the Dvd RUN SPLINTER CELL DOUBLE AGENT menu option.

    Are you getting any Runtime ERROR messages when you launch the Game, or any 'MUST check' message ? First make sure that you have fully updated the DirectX 9c runtime files, and all the VC++ redistributable packages from Microsoft's website. These must be updated.

    What are your full PC specs ? As a side note, Try this method which I'm giving below, if it does not work then something else needs to be done.

    Locate the game's Launcher i.e. SCDALauncher, and create a shortcut. After that insert the following command at the end of the target line, under the shortcut TAB:

    "C:\Program Files\Ubisoft\Tom Clancy's Splinter Cell Double Agent\SCDALauncher.exe" -ll

    Also give this a try:

    "C:\Program Files\Ubisoft\Tom Clancy's Splinter Cell Double Agent\SCDALauncher.exe" menu.unr -ll

    To force the game to use only DX9, you can also try this:

    "C:\Program Files\Ubisoft\Tom Clancy's Splinter Cell Double Agent\SCDALauncher.exe" -DX9


    You can also add the above '-ll' switch by inserting it under the Game's executable i.e. splintercell4.exe. Go to 'C:\Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System', and locate splintercell4.exe and create a shortcut of this file, and add the above command.

    "C:\Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System\splintercell4.exe" -ll

    Also look here under the Compatibility TAB, and check and tick the options Disable Desktop Composition, and 'Disable Visual themes'. Now click on this .exe and run the Game.


    If you are facing any kind of resolution issues, then you can also manually enter the Resolution values inside the splintercell4.ini config file. This file can be found under the same path i.e. Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System. Just look for the following lines i.e. FullscreenViewportX/FullscreenViewportY, and insert your Desktop's current resolution Mode.....

    Do you have a Dual-core CPU from AMD ? Have you installed the Dual core optimizer, if needed ?

    Are you playing Single Player or MP ? DX can be installed/updated from here, but if this doesn't include all the libraries, then look for an early version:

    http://www.microsoft.com/downl...1b-bc6a-9b6652cd92a3

    Btw, do you have this file i.e. xinput1_1.dll inside your 'Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System' path ?



    --------------------------------------------------------
    Share this post

  4. #4
    Originally posted by brogs60:
    SCDA will just not start, ..
    As an extra side note, if the above methods do not work, and/or the Game still doesn't launch under Windows 7, then try downloading and applying this fix which I've uploaded. But, first make a BACKUP of both the original executable (.EXE) files.

    This should work on all versions of the Game, since it looks like none of the patches (v1.01 & v1.02) have modified the main executable, and the file Checksum (i.e. for SplinterCell4.exe), Imo. MP may or may not work properly.

    http://www.2shared.com/file/yKLwA7s2/SCDA-fix.html



    ----------------------------------------------------
    Share this post

  5. #5
    Many thanks for your replies and hard work, these did the trick--"Also look here under the Compatibility TAB, and check and tick the options Disable Desktop Composition, and 'Disable Visual themes'. Now click on this .exe and run the Game."
    Cheers
    Share this post

  6. #6
    Originally posted by brogs60:
    these did the trick--"Also look here under the Compatibility TAB, and check and tick the options Disable Desktop Composition, and 'Disable Visual themes'. Now click on this .exe and run the Game."
    Cheers
    Thanks for updating, and your Reply......Good to know the game works now.


    ---------------------------------------------
    Share this post

  7. #7
    justinpunny's Avatar Banned
    Join Date
    Sep 2010
    Posts
    686
    Originally posted by KingDaniel0:

    Go to 'C:\Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System', and locate splintercell4.exe and create a shortcut of this file, and add the above command.

    "C:\Program Files <x86>\Ubisoft\Splinter Cell Double Agent\SCDA-Offline\System\splintercell4.exe" -ll

    Also look here under the Compatibility TAB, and check and tick the options Disable Desktop Composition, and 'Disable Visual themes'. Now click on this .exe and run the Game.
    I can confirm that the above method works on my copy of the game, and Windows 7 64 bit OS as well !

    Thanks for this, Kingdaniel.
    Share this post

  8. #8
    I have tried pretty much everything I could find on the web, but I still can not get past the loading screen. I would love to be able to play this game so I would be grateful for any help you can give me.

    My specs are

    Windows 7 Ultimate 64-bit
    Intel Core 2 Duo CPU P8400 @ 2.26GHz
    4096MB RAM
    NVIDIA GeForce 9800M GS

    One other thing. I downloaded the DirectX 9.0 executable from the site you linked, but I get this error when I try to run it:

    "An internal system error occurred.

    Please refer to DXError.log and DirectX.log in your Windows folder to determine problem."


    Let me know if you need any more information.
    Share this post

  9. #9
    This worked for me !
    Also look here under the Compatibility TAB, and check and tick the options Disable Desktop Composition, and 'Disable Visual themes'. Now click on this .exe and run the Game.
    Share this post

  10. #10
    Not working for me, too.
    In fact, I still haven't tried to apply this patch of ours (don't know why - can't download from 2shared), but my probelm is same as coolishmike's, so I'm probably screwed too.
    When I'll try the patch, I'll let you know if it works.

    EDIT: OK, problem solved on my PC (crashing while starting a new game). Guess what? Drivers...
    I had 275.33 WHQL, I've outdated it to 266.58 and it works perfectly now
    Share this post

Page 1 of 4 123 ... Last ►►