1. #1
    htimh's Avatar Junior Member
    Join Date
    Jul 2020
    Posts
    17

    Ice surface doesn't catch light on shader setting 'High'

    There's an issue with the ice & bobsleigh shader noticeable when you turn the mood to 'Night' and have lights shining towards the surface.

    How to reproduce:

    -Turn Shader settings to High
    -Create a map with Night mood setting
    -Place down Ice blocks
    -Place down light blocks facing the ice blocks
    -Calculate shadows (on any of the shadow settings)
    -You'll notice the ice surface is not lit up at all

    Here's some pictures

    Test map 1

    Shader Very high
    https://cdn.discordapp.com/attachmen...1-15-56-34.jpg

    Shader High (this setting has the issue)
    https://cdn.discordapp.com/attachmen...1-15-52-42.jpg

    Shader Low
    https://cdn.discordapp.com/attachmen...11-15-55-2.jpg

    Shader Very Low
    https://cdn.discordapp.com/attachmen...1-15-53-55.jpg


    Test map 2


    Shaders High (this setting has the issue)
    https://cdn.discordapp.com/attachmen...11-16-0-35.jpg

    Shaders Very Low
    https://cdn.discordapp.com/attachmen...11-16-6-15.jpg

    As you can see in these 2 pictures it's both the bobsleigh and the ice shader that are affected.

    In the next picture I:
    Placed a few lights,
    calculated shadows to see the result,
    and still having the light post still selected, the to-be-placed light DOES reflect light onto the surfaces
    https://cdn.discordapp.com/attachmen...478/zzddad.JPG


    My specs when I took the pictures:
    GPU 2080ti
    CPU i9-9900k
    32GB RAM

    SpammieJ's stream had this issue as well, he's playing on 'High' shaders
    https://www.twitch.tv/videos/833441821 (at 01:28:36)

    Friend's also had this issue on his 1080ti

  2. #2
    Hi, Indeed some local lighting are missing in that case.
    That bug will be fixed in next build.

    Thanks

  3. #3
    same goes for metal texture