1. #1

    Can't open map editor - 16bit color depth problem

    Hi, I have a problem with opening the map editor in Settlers 4.
    I tried to run desktop shortcut "The Settlers 4 - History Edition Map Editor", but then i have an error message:
    "Unable to start the graphics engine!
    Check whether Windows has been set to 16 bit colour depth (65536 colours).
    You can find more information on the error in the log file."
    So i tried to do it on my own tweaking in compatibility option on S4Editor.exe file... unfortunately with the same error result.
    Later i found file called "RunEditorEn.bat" so i tried to run this file. there were pop-up cmd windows with some messages and final ended with the same result....error message.
    I opened also "dxwrapper-s4editor.log" file but i didn't found any useful information.
    I paste it here anyway, maybe someone can see something:
    Code:
    1572 21:38:08.070 Starting DxWrapper v1.0.3897.21
    1572 21:38:08.070 Gigabyte Technology Co., Ltd. GA-MA770T-UD3P   (Desktop)
    1572 21:38:08.070 Gigabyte Technology Co., Ltd. GA-MA770T-UD3P x.x (Desktop)
    1572 21:38:08.070 NVIDIA GeForce GTX 1060 6GB
    1572 21:38:08.071 Windows 10 64-bit (10.0.19041)
    1572 21:38:08.071 S4Editor.exe (PID:756)
    1572 21:38:08.071 Reading config file: dxwrapper.ini
    1572 21:38:08.072 Disabling High DPI Scaling...
    1572 21:38:08.072 Loaded library: Shcore.dll
    1572 21:38:08.072 Set exception handler
    1572 21:38:08.072 Loaded library: kernel32.dll
    1572 21:38:08.072 Finished setting exception handler
    1572 21:38:08.073 Hooking ddraw.dll APIs...
    1572 21:38:08.074 Process path: G:\Gry\thesettlers4\Editor\S4Editor.exe
    1572 21:38:08.074 Loading DDrawCompat from G:\Gry\thesettlers4\Editor\dxwrapper.dll
    1572 21:38:08.076 Loaded library: uxtheme.dll
    1572 21:38:08.077 DDrawCompat v0.2.1 loaded successfully
    1572 21:38:08.078 Loaded library: G:\Gry\thesettlers4\Editor\dxwrapper.dll
    556 21:38:08.111 Starting fullscreen thread...
    1572 21:38:09.322 Installing DirectDraw hooks
    1572 21:38:09.484 Installing GDI hooks
    1572 21:38:09.497 Installing registry hooks
    1572 21:38:09.497 Finished installing hooks
    1572 21:38:09.506 Loaded library: winmm.dll
    1572 21:38:09.554 Loaded library: dwmapi.dll
    1572 21:42:57.751 Quiting DxWrapper
    1572 21:42:57.751 Detaching DDrawCompat
    1572 21:42:57.761 DDrawCompat detached successfully
    1572 21:42:57.761 Unhooking APIs...
    1572 21:42:57.761 Unloading libraries...
    1572 21:42:57.761 Unloading exception handlers
    1572 21:42:57.761 Reseting screen resolution...
    1572 21:42:57.775 DxWrapper terminated!
    I didn't only change options in "dxwrapper.ini", because i don't now what to change in it.
    I paste it here also:
    Code:
    ;; Config file for DirectX DLL Wrapper
    [General]
    RealDllPath              = 
    LoadCustomDllPath        = 
    RunProcess               = 
    WaitForProcess           = 0
    
    [Compatibility]
    D3d8to9                  = 0
    DDrawCompat              = 1
    DSoundCtrl               = 0
    ConvertToDirectDraw7     = 0
    ForceTermination         = 1
    
    [Plugins]
    LoadPlugins              = 0
    LoadFromScriptsOnly      = 0
    
    [Window]
    FullScreen               = 0
    ForceWindowResize        = 0
    WaitForWindowChanges     = 0
    Does anybody had some similar issue with editor?

    My 9-year-old son is crazy about this game right now, just like I was in the good old days years ago.
    Now he wants to create his own world and I feel obligated to help him with it.
    Can anyone help me to fix this problem, please?
    Share this post

  2. #2

    Problem solved!!! .... by accident :)

    Recently I changed the monitor to a new one and .... the editor started working !!!
    So I started to wonder what the difference was. It turned out that the problem was ... RESOLUTION.
    The new monitor is of Full HD (1920 x 1080) standard, and my earlier DELL has a slightly weird 1680x1050.
    So there is probably some set of resolutions that this editor supports and all the others will get you in trouble
    I am very glad that I finally solved this problem. And my son is even happier than me
    Share this post

  3. #3
    Ubi-Ginge's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    2,564
    Pleased to see you got this resolved crisis_cris!
    Hope you and your son enjoy
    Share this post