1. #1

    Can't Load Story - Possible Cause - Solution?

    I've seen a few similar threads on here with no definitive solution, and have also spoken to Ubisoft support, who just ended up recommending I post the details here.

    It relates to seeing this very generic message when trying to load a story:



    In case it is relevant, I am running the game on PS4, editing the stories on a Windows 10 machine using the chromium version of Edge.

    FWIW I am a software developer myself, so am fairly accustomed to tracking down bugs and reproducing them and have narrowed down the trigger (or at least, one possible trigger) for the issue I am seeing.

    My story is a humorous quest based on the scene in Bill & Ted's Excellent Adventure where they meet Socrates and - long story short - they say their time machine is broken and we are going to help them fix it.

    So, I created two custom quest items, once called "Broken Antenna" and one called "Fixed Antenna":



    In the quest, I take the broken item to an NPC who I set up as a blacksmith (called "Hephestia"), I go off to run an errand for them, and when I return they give me the fixed item:



    I have tracked down the problem I am seeing to the transaction where the "Fixed Antenna" is returned to me. If I remove that transaction from the dialogue (and the additional output that is then no longer needed), the story loads and works just fine. If I put it back in, it fails to load again.

    Now obviously I could just not have the item and the story would flow pretty much the same, but I'd like to be able to have it.

    Things I have tried to work around this:

    1) Making sure the two items have different icons

    2) Making sure they have completely different names

    3) Making sure there are no unusual characters in the item names or descriptions

    4) Creating an additional character, an assistant to the blacksmith, and have them as a silent member of the dialogue who gives the fixed antenna to us

    5) Making sure all the quests and stories have output wired up to outcomes, no obvious other errors

    6) Checked Hephestia has the item assigned to her inventory:



    7) Removed the additional item Hephestia has in her inventory ("Medicine")

    None of these resolve the problem.

    So, I am posting this in hope someone may have an idea how to resolve this, and because perhaps it might give some ideas to other people who are seeing this same message (though of course it is very generic so there are probably lots of reasons it might display).

    Any thoughts, ideas, tips, etc. gratefully received!
    Share this post

  2. #2
    Ubi-Borealis's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    1,829
    Hello there alberyjones! Thanks for such a detailed report. It's interesting to hear what you have tried and discovered. I must also say that your story, based on Bill and Ted, also sounds like a lot of fun! I hope we're able to help you to publish it successfully

    I can see that you've posted over on this thread about your investigation. Have you had a chance to read through this thread to see what one of the developers, PinkHusky433, has shared about their discoveries with this error? For instance, they mention how they found out that when they get the error, it is very likely that they made a logical error (e.g. set a Talk Objective before a Free Objective with the same NPC).

    You mention that the error seems to be linked to receiving the fixed antenna from Hephestia. It may be worth checking that there are no logical errors occurring here.

    Have you also been able to try browser troubleshooting, as advised by my fellow colleagues?
    Share this post

  3. #3
    After a lot of fiddling around I have got this working. The thing that seems to have made the difference was off the back of @PinkHusky433 's information on the other thread - I didn't need to do exactly what was described with variables, but I went through each of the dialogue items in each quest and wherever I had a set up like this:



    I changed it to this:



    There is no change in logic, but it reduces the number of outputs from the dialogue to just one. The "Fail" outputs from the inventory items (not entirely sure how they would fail in any case - perhaps if the character did not have the item?) now just join to the single output, rather than a separate one.

    Having done this throughout the whole story, it now loads successfully. Hopefully this is of use to someone else!
    Share this post

  4. #4
    Ubi-Borealis's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    1,829
    Thanks for the update, alberyjones, and for sharing your solution! I'm glad your story now loads successfully! Hopefully your own experience (and accompanying images) can help other players encountering this issue
     1 people found this helpful
    Share this post

  5. #5
    In case anyone is interested, my published story is here:

    https://assassinscreed.ubisoft.com/s...1cde1660af3808
    Share this post