1. #1

    Missing "monster of the sea" mission

    PC user. Unable to start the frontiersmen mission "monster of the sea". I have finished any other frontiersmen missions, completed the main game, and any requirements to start this mission, but there's no symbol showing up on the map. I tried to find the travellers in the taverns of Boston but there's no way to start conversation there. My animus database isn't showing up "monster of the sea" and the frontiersmen mission is not completed so I'm sure I haven't played this mission.
    Share this post

  2. #2
    I also tried restarting game and verifying documents. Nothing worked.
    Share this post

  3. #3
    So, you're saying you've been to the location it should be, but it's non-existent? I do remember that in the original ACIII, there was an issue where even mission markers wouldn't show up in places you'd never been & it's one of only a few games in the series where the viewpoints don't allow you to see everything, so you have to wander around & hope you get close enough to something for it to register on the map.
    Share this post

  4. #4
    Usually frontiersman missions would be marked on the map once the prerequisites are met. I've definitely met the prereqs (full Boston map discovered, all other frontiersman done, main game finished), but this mission isn't showing up as it should be.
    I checked videos online about this mission and no one mentioned having to find it first.
    Share this post

  5. #5
    Well, it would only be if you haven't explored the part of the map where it is. You'd have to happen to wander close enough to it to trigger the icon to appear. It would still exist one way or the other, though. Unless, they changed that in the Remaster.
    Share this post

  6. #6
    I play AC3 Remaster again these days, so I can definitely say that the frontiersmen missions are always in the same order.

    The Boy Who Cried Wolf
    Finding The Sasquatch
    The Haunted Lighthouse
    The Headless Horsemen
    Monster Of The Sea
    Unidentified Flying Object

    The first four in frontier, the last two in Boston.

    If you say you didn't play the sea monster, then you didn't play Unidentified Flying Object as well, because UFO is the last mission. And I read many posts about problems with the UFO mission. I play PC as well and had no problems with all these missions. Are you sure it is the sea monster mission, you are missing? I didn't hear it before.
    Share this post

  7. #7
    I played UFO mission and I don't remember playing sea monster mission. My animus database isn't listing sea monster mission either (which should have a log from Sean when the mission's finished).
    Share this post

  8. #8
    I have the whole Boston map unlocked and synched though? I even tried going to all the pubs, the traveller's just not there.
    Share this post

  9. #9
    Is AC3R's dev team still taking feedback or have they moved on... Smh
    Share this post

  10. #10
    Ubi-Ginge's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    2,073
    Hi MHwtf!
    Sorry for our delay in responding.
    Would you be able to share screenshots showing your map and the quests available to you
    Share this post