1. #1

    Twich drops don't work (again)

    Following all the steps in a live show, the drops still don't work, which happened last time and I missed the prizes. I hope they solve it or do another way to get those prizes, because I'm faithful to the game and I don't want to miss anything ... it's a twich theme and it's been going on since before wardlords ...
    Share this post

  2. #2
    I have changed to a new twich account and it still does not work, I changed direct and they are not activated either ... it is a problem with my account. Please have a moderator answer me and solve this problem for me. They never respond to me on this forum ... it's a shame.
    Share this post

  3. #3
    SerjTargaryen's Avatar Member
    Join Date
    Feb 2019
    Location
    Russia
    Posts
    133
    the same for me. I see "Enable in-game Drops with Account Link." Then I go to https://drops-register.ubi.com/ (it says it's ok - your Ubisoft and Twitch accounts are linked)... Come back on twitch and see again "Enable in-game Drops with Account Link."...

    Missed previous rewards and again...
     1 people found this helpful
    Share this post

  4. #4
    It is the story that never ends ... I have made several posts before and never received a response. Neither here nor in twich ... they are never activated ..... I do the same thing you say, and it tells me that if they are active, but then in the stream they do not appear active, I think it must be a problem with some accounts. .. I have friends who always activate them and are always the same, and I have others who, like me, can never activate them .... Please, we need answers and help.
    Share this post

  5. #5
    UbiT00n's Avatar Community Representative
    Join Date
    Jan 2020
    Location
    Base Of Operations
    Posts
    1,883
    Please check our support page here: https://support.ubisoft.com/en-GB/fa...-Twitch-Drops/

    " Rewards will be delivered a day after the stream"
    Share this post

  6. #6
    SerjTargaryen's Avatar Member
    Join Date
    Feb 2019
    Location
    Russia
    Posts
    133
    Originally Posted by UbiT00n Go to original post
    Please check our support page here: https://support.ubisoft.com/en-GB/fa...-Twitch-Drops/

    " Rewards will be delivered a day after the stream"
    It's not about rewards. The Twitch says your accounts not linked under the video... but they are linked. It means I won't get rewards at all... I had the same problem last The Division 2 Twitch Drops. I created a ticket with screenshots to explain it. Ticket 12764118

    https://imgur.com/0roUWwi

    it says Enable in-game Drops with Account Link. but it must be Drops enabled that's why my viewing doesn't count. The notification says LINK IT. But they are LINKED.
     1 people found this helpful
    Share this post

  7. #7
    Exactly, the same thing happens to me, it says that if they are activated, but in the stream it is never activated ... then in an error of my ubisoft account, and several more ... in fact I even made a new account of twich and everything remains the same ... I have friends that if it works for them and they are the same that it always works for them ... but for others never as is my case ... it is a mistake that they should solve, or at least let the gifts be get into the game.
    Share this post

  8. #8
    Ubi-Keo's Avatar Ubisoft Support Staff
    Join Date
    Jul 2017
    Location
    UK
    Posts
    4,793
    It's possible that this issue is related to having another Twitch account linked to your Ubisoft account in the past.

    I have checked both of your accounts and can see that you have both had different Twitch accounts linked to your Ubisoft account in the past. I would recommend trying to unlink your current Twitch account and link the previous Twitch account again and test if that works.
    Share this post

  9. #9
    Let's see, all this they say we already did. I manually entered the ubisoft account and unlinked all the accounts, and then re-linked them ... and there are no changes .. and this is not from now, it comes since warlords came out .... so it is an extra problem. If you have the way to solve it, because I did devicular about 20 times and everything remains the same ... I even created a new account today, and it does not link me.
    Share this post

  10. #10
    I just tried to do it all over again, and nothing changes. The drops are not activated in the stream.

    My twich Id is sectorarg, if there is another one, please unlink it if you can. Thank you
     1 people found this helpful
    Share this post

  11. #11
    SerjTargaryen's Avatar Member
    Join Date
    Feb 2019
    Location
    Russia
    Posts
    133
    Originally Posted by Ubi-Keo Go to original post
    It's possible that this issue is related to having another Twitch account linked to your Ubisoft account in the past.

    I have checked both of your accounts and can see that you have both had different Twitch accounts linked to your Ubisoft account in the past. I would recommend trying to unlink your current Twitch account and link the previous Twitch account again and test if that works.
    I did it several times! Unlinked it via Ubisoft profile and linked them gain. Nothing changed
    Share this post

  12. #12
    SerjTargaryen's Avatar Member
    Join Date
    Feb 2019
    Location
    Russia
    Posts
    133
    Yes. i restored my previous Twitch account and linked them...Seems it works now
    Share this post

  13. #13
    Ubi-Keo's Avatar Ubisoft Support Staff
    Join Date
    Jul 2017
    Location
    UK
    Posts
    4,793
    Originally Posted by SerjTargaryen Go to original post
    Yes. i restored my previous Twitch account and linked them...Seems it works now
    Thanks for confirming this. I'm pleased to hear that it has worked.
    Share this post

  14. #14
    Originally Posted by Ubi-Keo Go to original post
    Thanks for confirming this. I'm pleased to hear that it has worked.
    Can you do something to help me? I don't want to miss another award again because of a platforming bug. The only account that I have linked to twich is the current one. The others no longer exist ...

    Uplay Id: Sector.ARG
    Twich Id: SectorARG
    Share this post

  15. #15
    Can you do something to help me? Thanks!
    Share this post

  16. #16
    Any moderator who can help me solve this problem? Or at least tell me the way to do it so I can get the prizes from twich ... I have no way to reactivate the old accounts. I already left my uplay ID and my twich account ... help me get these drops and the ironhorse raid. Thank you.
    Share this post

  17. #17
    Anyone who can help me? Please, I don't know what to do anymore ... some moderator ... I couldn't find a way to make a report about this matter ... I want them to leave me my current twich account synchronized ... according to another moderator above, it is for having changed accounts. But even, having an account for several months, they were not activated. I would like you to give me instructions. I can no longer reactivate old accounts, because the email is in use with the current one. I leave my IDs again

    Uplay ID: Sector.ARG
    Twich ID sectorarg / SectorARG (original / public)
    Share this post