🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Anno 2070 missing UI element text


    There is no text in any of the UI elements and I can't type in the log in box.

    1. I've reinstalled the game twice
    2. Run the autopatcher (just launches the game),
    3. The offline patcher (tells me either; Its not installed, is already up to date, or is corrupt and needs reinstalling)
    4. Uninstalled again then searched my hard drive for anything to do with Anno or Uplay and removed it and reinstalled.

    When I remove the Deep Ocean DLC with steam I get UI text back but in an endless loop asking me to reboot the fix mentioned here: https://support.ubisoft.com/en-gb/Fa...ing-Deep-Ocean doesn't seem to work, so its not even playable without the DLC.

    If anyone has any advice I'd really appreciate it.
    Share this post

  2. #2
    Share this post

  3. #3

    May it help you as well


    Had the same issue. I bought the game over Steam. When disabling the Deep Ocean DLC and also the Key I was able to start the game but hat the reboot issue as you had.

    I then found this article.
    After using this reworked autopatcher http://www.mediafire.com/download/na...utoPatcher.rar is described in the site above. The game would patch. It wanted my key and I was quiet reluctant to provide it, but as I could not use the game in this state, I did not care to much about it. It would then properly patch the game.

    Sitenote: I do not know if related as I tried multiple things in order to get it to work. When I tried to start the game again it would not work as according to Uplay my Key was not valid. I made a copy Anno5.exe before trying about what I found on the net. After renaming the copy from Anno5.exe back to it's original name and discarding the existing one it seemed to work.

      • Make a copy of Anno5.exe just in case
      • Disable all DLC for ANNO 2070 in Steam
      • Replace the AutoPatcher with the one that can be downloaded here http://www.mediafire.com/download/na...utoPatcher.rar
      • Start the "new" AutoPatcher.exe - After completing the autopatcher it should let you start the game and it should be working
      • Should the game not start when trying to start it the next time replace the existing Anno5.exe with the backup you made in step 1

    Hope this helps you as it helped me
    Share this post

  4. #4
    Ubi-WheelyDuck's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Hey guys,

    Great to see you found a solution that works for you.

    If ever we can help in the future just let us know
    Share this post

  5. #5
    How I fix it was I bought the deep ocean through Uplay again. Now any time I reinstall the game I have no loop problems.

    What I think is happening is yes you own the deep ocean. But for some reason Uplay never really added to you account.

    Yes people have all these work around's, but the thing is Uplay really has to fix problem. This has been going for yrs too.
    Share this post

  6. #6
    Ubi-Milky's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Hi everyone,

    Sorry to you have all been experiencing this auto patcher issue. We did release our own fix but for the majority of players this did not solve the issue if they bought the game through Steam. Uplay did not seem to have this issue.

    As dmdilks said, some players found installing the alternative patcher from other sites did work for them although this is not ideal, it is a workaround for the time being, and we ask players to always be wary of external links to non official sites just in case.

    I can however report that last month we pushed an update to Steams Anno 2070, that upon reinstallation of the game, the autopatcher issue should now not exist.
    Share this post