🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Can't start Anno 1404 and 1701 History Edition but Anno 1602 and 1503 work perfectly.

    Hi There,

    I am running into a problem when starting the game Anno 1404 and Anno 1701 from the History Edition Collection.

    An error message pops up, titled Anno1701.exe / Anno1404.exe saying that:
    "The application was unable to start correctly (0xc000007b). Click OK to close the application."

    What did I do to solve the problem?

    Inspired by internet research, I installed all NET. Framework -, DirectX - and Microsoft Visual C++ - packages, using the program All in One Runtimes and the installers provided by UPLAY in the Support Folders of these two Anno games 1701 and 1404.

    In addition, I let Windows recommend a Compatibility Mode for the executable files and let the programs run as administrator and added an exclusion to the anti-virus program for the UPLAY Install Folder of the Anno History Edition Collection.

    Technical Observations:

    The only weird thing I could find so far was that the DirectX Diagnostic Tool showed Current Display Mode: 1920 x 1080 (32bit) (59hz) in the Display Tab and I read that Anno 1701 and 1404 are completely converted to 64bit for the History Edition, which means it would cause problems if my display settings would be set to 32bit while trying to run a 64bit game.

    I am sure my device is based 64bit and as far as I know, you can't just switch between 32bit and 64bit. Maybe a 64bit system can be compatible downwards with for 32bit applications but not the other way around.

    System Info

    Dell Inspiron 7790 AIO - x64 - Windows 10 Home [10.0.18363]

    Microsoft Visual C++ 2005 | 2008 | 2010 | 2012 | 2013 | 2015 | 2015-2019 ---- all in 32bit & 64bit

    DirectX 12.1

    .NET Framework 1.0: not installed.
    .NET Framework 1.1: not installed.
    .NET Framework 2.0: installed with service pack 2.
    .NET Framework 3.0: installed with service pack 2.
    .NET Framework 3.5: installed with service pack 1.
    .NET Framework 4 Client: installed with no service packs.
    .NET Framework 4 Full: installed with no service packs.
    .NET Framework 4.5: installed with no service packs.
    .NET Framework 4.5.1: installed with no service packs.
    .NET Framework 4.5.2: installed with no service packs.
    .NET Framework 4.6: installed with no service packs.

    .NET Framework 4.8: Automatically installed and updated with Windows 10 ### I think?!

    Thank You

    OK, thanks for your time and for looking into this. I hope I provided enough details to enable someone to tell me what I can do to play my beloved game series.
    Share this post

  2. #2

    Additional Information

    Additional Check Up's

    Performed a .NET installation check using the program .NET Framework verification tool which showed no errors.

    The program CheckDotNet reports that .NET Framework 4 - 4.6 have no service packs installed as you can see it more detailed in the bottom of my previous post.

    Additional Technical Observations:

    When checking the UPLAY Launcher in the Windows Task Manager, it shows me one app called Uplay launcher (32bit) and its two processes. The first one is called Uplay and the second one is called Uplay WebCore (32bit). It should not make a difference but I wanted to mention it since I am using a 64bit device and I am desperate to play Anno 1404 again.

    Share this post

  3. #3

    Issue solved

    Hi There,

    The games work perfectly now and for other players that experience the same issue, I would like to share what I came across.

    Claim 1:

    The DirectX Diagnostic Tool showed a Current Display Mode: 1920 x 1080 (32bit) (59hz) in the Display Tab. Turns out that this had nothing to do with the error message I was getting and there is nothing wrong with a 64bit os using a 32bit display mode.

    Claim 2:

    .NET Framework had no installed service packs caused this issue. Nope that was not the case.

    Claim 3:

    UPLAY Launcher was listed as 32bit application in the Windows Task Manager. This is not an issue at all.

    Claim 4:

    Compability Mode was not set up right. This also was not the issue.

    So what fixed the issue?

    This problem can be caused by different things and in my case, I deleted all the d3d dll files in the Windows System32 Folder [some could not be deleted] and used the DirectX 12 Offline Installer. Previous to that I used the program .NET Framework cleanup tool to check and fix the .NET Framework installations and deleted all Microsoft Visual C++ installations except 2005 and reinstalled 2010 again.

    I just mention the later two things for completion but i think it was the DirectX issue.

    Share this post

  4. #4
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019

    I'm very sorry I was unable to reply to you sooner, I can see the issue has already been resolved.

    The way you formatted this thread is brilliant; it makes it very easy to understand what you have tried and what your thoughts are.

    In the hope that this helps a little - I believe the 32bit is in relation to your monitor's colour depth, it has a different meaning to your 64 bit operating system

    All the best!
    Share this post