1. #1

    Season 2 menu problems

    Having problems with the season 2 menu locking up and not letting me do anything.

    happens whether i open it myself or everytime i fast travel it pops up. have to close the game and reopen to get it to go away.

    Is anyone else getting this or is there a fix for it?
    Share this post

  2. #2
    UbiExcellent's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Posts
    204
    Welcome to the Forums, sirgitano! I'm sorry to hear about this issue you've encountered recently. Have you tried verifying the game files to see if this fixes the error? If not, please give this a try. Additionally, if you could send me a video showing this issue occurring, I'll be happy to look into this further with you.
    Share this post

  3. #3
    i have verified the files
    Share this post

  4. #4
    Same Problem here. I tryed verify game File's. Also uninstall + reinstall didnt worked. Keeps showing just the background of Season 2 Menu, when using fasttravel, acces it over the NPC's and over the tab in Escape Menu. Shouldnt be so hard to push out a hotfix for that! The problem wasnt there before Season 2 (season 1 worked fine!).
    Share this post