1. #1

    Shame on Ubisoft

    Something quite remarkable happened to me today, I launched Anno 1800 and get notified that an updated is available and recommends me to download it .
    I do it of course and a box opens on my desktop showing me the download progress.
    So far so good until i see on the right side of the box in blue something that says game details and thinking that it would give me some details of the patch , I clicked on it, but instead of opening another box with info or the UPLAY software, the box downloading the update closes.
    I get another little box a few second later saying it has finished downloading the update so I double click on the Anno 1800 Icon and get a message that the game file is corrupted

    Seriously Ubisoft???????????????

    In 2020 you can still allow this kind of BS to happen, why is there a message on the download box info saying game details when there is no link to anything but actually messes up the download. I had to run the file checking tool in UPLAY and after taking for ever I am going to see if it fixed your mess.

    Keep you posted...................................
    Share this post

  2. #2
    Ubi-Woofer's Avatar Ubisoft Support Staff
    Join Date
    Aug 2019
    United Kingdom
    Hello gwenaellp,

    Would you mind clarifying exactly what the message you clicked on said? There are a number of pop-up messages that Uplay PC can communicate, so without knowing what you clicked on, I'm afraid it is difficult for me to understand what has happened. The update window is normally separate to the main Uplay PC window if referring to the updates before a game fully launches, so if you clicked on the main Uplay PC window, I imagine the update one may have just gone into the background?

    The file verification process in Uplay PC should fix any corrupted data; if issues should persist, reinstalling the game would be the next step after that.
    Share this post

  3. #3
    The update window was separate from the main uplay window, that is not the issue. The problem was that within the update window there was a line saying game details to click on and when i did the update window closed. I was then notified that the update had finished downloading and then nothing .
    When i tried to launch the game i got an message that files were corrupted , so the fact that the update window had closed while downloading the update messed up something.
    After i used the file checking within Uplay it fixed the issue , but the file checking takes a while and i should have never had to do that in the first place.
    I still get too many times an error message saying that the saved files on the cloud failed to synchronized and i have to try a few times before Anno 1800 is able to start properly.
    It a shame that as players we have to deal with things like that from a company like Ubisoft which has been in the PC gaming business for a long time and issues like that shouldn't happened anymore.
    I recently purchased Anno 1800 and it is a great game , one of the most immersive one i have played in a while , but issues with Uplay makes no sense from a company like Ubisoft.
    By the way , there is a problem within the game when a competitor ask me for example to escort one of their ship and when i get close to it with my ship nothing happens , no windows opens to ask me if i am ready to escort the ship and i can't start the mission. It doesn't happens every time but it does happens occasionally.
    Share this post

  4. #4
    Ubi-Litten's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    No problem, thanks for getting back in contact and letting us know you have been able to get this query resolved.

    We will certainly forward your feedback for further review as we are always looking for ways to improve our services, but If you have any other questions, please feel free to let us know..
    Share this post