1. #1

    Unplayable with speed issues after upgrading Android

    Edit: Performance isn't ideal and the game hangs a lot, but this has improved in Android 10 and I think I'll just live with it. Old device and all.

    I noticed at the end of May that the game's online features stopped working. After heading to the forums to see what's up, I noticed my browser was complaining about an invalid SSL certificate, and only on my phone - computer was fine. So I put two and two together, and figured it was time to upgrade Android. Other websites didn't complain, but still. And so I upgraded, from version 5 to 9. Yeah... I put it off a while. Custom ROM, if you're wondering how I got more than the usual manufacturer 2 years of updates.

    But on Android 9, the game isn't right. Vibration is off, but big deal. The important thing is I'm getting the dreaded speed issues - the whole game is mainly speeding up, making the bike very difficult to control. I know users have had trouble with game speed for years, but I'm really hoping I can continue to enjoy the only mobile game I play.

    I don't think this is particularly relevant, seeing as it was working fine on the older Android version, but my device is the Samsung Galaxy S5.
    Share this post

  2. #2
    Originally Posted by Ihateuplaykk Go to original post
    I noticed at the end of May that the game's online features stopped working.
    I had same issue with my old bluestacks 2 emulator (with android 4.4.2) where I record videos for my tf world records channel. I solved it by importing certificates from game server, now it works fine. I used that tool (needs root) https://play.google.com/store/apps/d...Importer&hl=ru and imported certificate from that website (android game server): https://lb-rdv-http.ubi.com/TRIAG_AN_LNCH_A/public/
    I don't know if there's a method to import them without root privileges
    Share this post

  3. #3
    Just found a solution how to solve it without root. There's a security menu in the android settings that allows you to import certificates from sdcard. You can save them manually from browser on the pc and import through that menu.
    Share this post

  4. #4
    I'm not going to downgrade Android, but this is good to know nonetheless. If I hear of anyone else having trouble with the game being unable to connect to the servers due to certificate issues, I'll be sure to pass this information along!
    Share this post

  5. #5
    Ubi-Woofer's Avatar Ubisoft Support Staff
    Join Date
    Aug 2019
    Location
    United Kingdom
    Posts
    2,865
    Hello Ihateuplaykk Thanks for reaching out here on the forums.

    That does certainly sound like a huge leap from version 5 to 9 - the game is likely to feel different on this OS. You've specifically mentioned that the game seems to "speed up" compared to before, however - are you able to record your gameplay using the Android screen capture on your device, and prepare a short clip of the issues for me / our mobile games team to review?

    Can you also tell me what your current exact OS version is on your Samsung Galaxy S5, and whether the game itself is fully-updated?

    negodyaeff - Thank you for offering your own insight and workarounds here.
    Share this post

  6. #6
    Having a similar issue on my Galaxy S20+ 5G after the os updated to Android 11, One UI v3.0. The whole game including menus etc is running at approximately double speed making the game impossible to play. Tried doing the old un-install and re-install which made no difference. I think the game is at v7.9.1 which is displayed bottom right on the options screen.

    Also, Midnight Circuit is still broken. Same issue as everyone else, lets you race one track then that’s it, fails to list your score and ranking almost like it can’t connect to the server.

    Finally, is it just me or have there been no posts on Facebook since the HD EV was announced back on the 17th Jan?

    Come on guys, fix the issues and keep the community updated. 🙄

    Stay safe
    Share this post