1. #1

    stuck on splash screen

    When try to launch the game ac origins it stuck on the splash screen.
    on the task manager it doesn't shows not responding.
     2 people found this helpful
    Share this post

  2. #2

    moi pareil

    pareil
    Share this post

  3. #3
    Ubi-Litten's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    732
    Thank you for providing this information and sorry you are still experiencing this issue while launching your game.

    So we can investigate this further could I first ask that you have attempted our basic troubleshooting steps as outlined here.

    If you are still receiving this error after completing these steps, could you please update us with your system specifications and system reports as advised in the FAQ guides below :

    Generating a DirectX Diagnostic Report

    Generating a Microsoft System Information Report

    Once we have this information our technical support team will be able to look into this and assist you further.
    Share this post

  4. #4

    Stuck on the splash screen

    I purchased Assassin's Creed: Origins yesterday and have been unable to play it. The game simply won't launch, I've tried various fixes I've seen such as:

    - Turn off antivirus
    - Turn off background applications
    - Verifying files
    - Uninstalling the client
    - Uninstalling the launcher
    - Turning off FXAA from Nvidia control panel
    - Launch from offline
    - Launch as Adminstrator
    - Updated Graphic driver

    I also tried to download fixes from other site to no avail. I simply don't know what else to do
     1 people found this helpful
    Share this post

  5. #5

    Experiencing the same issue

    I am experiencing the same issue.

    The game begins launching, enters splash screen and then crashes.

    I have also reported the issue to the support team and was asked to do the same things as you have said you tried. Still not able to launch.

    I have owned the game since it came out and was able to play it just fine the last time I played a year ago. I reinstalled recently and now it wont launch.

    I have not changed any of my hardware and I am able to play all of my other computer games (including other Ubisoft titles).

    Let me know if you come right with this issue please.
     1 people found this helpful
    Share this post

  6. #6
    I purchased the game 2 days ago and on the first day it launched just fine,on the second day it happens exactly the same as carmiog's case, stuck splash screen and task manager showing the game running...All my other uplay games work flawelessly.
    Share this post

  7. #7
    Any update if anyone found a solution ? I can't figure out why it's not running and it's so frustrating...
    Share this post

  8. #8
    After i managed to run the game ( i've installed it in other hard disk) after doing a main quest my savegame is ruined and all of my process as well,i keep getting failed quest and when i reload the same quest i get the same message, thank you Ubi for not having a manual savegame as in Odyssey, i regret it when i purchased this game and let all my friends know about this buggy game, what a pity...
    Share this post

  9. #9
    Share this post