1. #71

    Fixed my crashing issue

    Hello All,

    After working with support (and finding their suggestions unhelpful) I figured out what the issue was that was causing this. I had to uninstall my VPN software entirely. NordVPN was stopping something from running.

    My thinking is Ubisofts crap DRM (denuvo, I think?) was tripping over my VPN.

    Either way the game is working now, no thanks to Ubisoft.

    Its sad, its a really great game, just wish I didnt have to uninstall my VPN in order to play it.
     1 people found this helpful
    Share this post

  2. #72
    I have the same problem. when I press on "load" the game crashes to the desktop. this game is over one year old and its still such crap again and again :/ and always the same answers by ubisoft. the driver, the vpn, reinstall the game... I bought a complete new computer and I still have the problem. why do I pay money for this
     1 people found this helpful
    Share this post

  3. #73
    Game Crashes when you resize the window in Widowed Mode. (not full screen).
    Share this post

  4. #74
    I had something similar.

    Try running the DX12 benchmark and re-try the game.

    Also the game crashed for me because I was maxing out my available RAM.

    I therefore increased the page file size on the window SSD and the SSD the game was installed on.

    Also closing Firefox and Chrome that use plenty of RAM helped.

    Can those who are having the problem report the system RAM usage?
    Share this post

  5. #75

    crashes pc

    mine is even worse. just got the game yesterday, after install, and launch, it just does nothing. reinstalled, asked for update, now game crashes, or it crashes the entire pc. i'm looking to get a refund from epic, but really, i would like to try and play the game.
     1 people found this helpful
    Share this post

  6. #76

    Utterly fed up with Ubisoft Support

    I bought this game at a premium (deluxe at that) when it first came out on STEAM. After about 10 hours play (despite steam reporting 60 hours), a ubisoft uplay update made the game crash on startup.

    Move forward a year, and I've still not played it - support are just trying to get rid of me rather than actually helping! 3 DLC's and I've paid none of them despite having paid.

    What I tried:
    Working offline (STEAM&UPLAY)
    Unplugging network
    Reinstall anno
    Reinstall anno to new locations (same drive)
    Clean windows boot
    Clean driver installation
    Clean Windows 10 installation
    Running from Steam
    Running from UPLAY
    Running from bin folder
    All .exe with/without admin rights
    DPI set to 100% (WTH ubisoft - this was nonsense)
    Turning off game overlays.

    Most recently (aside from a whole load of almost superstitious attempts as fixes), they made me create a new admin installation of windows 10, reinstall steam, uplay and anno. I new it wouldn't work, but they are arrogantly refusing responsibility for the issue even though THEY CAUSED IT. Instead they are claiming it is my PC's problem.

    They have wasted my time, and STEAM refuse a refund as it was used for more than 2 hours. I will NEVER *buy* another UBISOFT product again, as my experience has been so negative I couldn't recommend anything released by them. I cannot even get my money back. It's like daylight robbery, and the customer is the victim.

    I will raise this with trading standards, and will see if I can get a few people together to take a class legal action designed to highlight what they have done to it's paying customers.

    To show how angry I am about this: I had a job application with UBISOFT as a Senior Analyst. have pulled it as I will not work with unprofessional organisations.

    SORT OUT THIS PROBLEM UBISOFT - PROTECT YOUR CUSTOMERS
     1 people found this helpful
    Share this post

  7. #77

    Anno1800 crash

    Anno 1800 has been crashing on me regularly the last few days. my drivers are up to date and I am happy to cleick the button to submit a crash report. What else should I do?
     1 people found this helpful
    Share this post

  8. #78

    Possible solution (worked for me)

    Hi all,

    Try this - it worked for me when I got desperate!

    1. Navigate to C:\Ubisoft Game Launcher\savegames\dadd46f5-6fc9-4979-8740-c1219595c738\ -- assuming " C:" is your install drive

    2. Change the folder name of "4554" to "_4554". -- This removes ANNO 1800's save games.

    3. Try and run the game.

    It's possible the savegame folder isn't always 4554 - in which case you need to figure out which one is! Renaming "savegames" folder would also work, but would affect all saves.


    Good luck - please reply if this works and let others know
    Share this post

  9. #79
    Had the same issue with Anno 1800 crashing to desktop with a DirectX error after the 8.1 update. Experiences from the past got me thinking the reason could be something ship/harbour related causing this (ships on trade routes did behave odd at times the first year after all...) so yesterday I started looking at all harbours for ships showing odd behaviour. After another crash I found one ship at a not so important trade route at the edge of the map; a blue sign indicated it was busy but nothing happened: it wasn't loading/unloading anything and didn't move though the route was not paused... So after a minute or so I paused and unpaused the route, the ship then continued its route and after that there was no more crash. Today I did play for hours but the crash did not return.
    Share this post

  10. #80
    Ubi-WheelyDuck's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    68
    Hey all,

    It is great to see you sharing your experiences and solutions. If anyone is still experiencing this issue please don't hesitate to let us know as we are more than happy to help!
    Share this post