1. #1

    Map Editor in Swedish???

    I recently had problems with Far Cry 4 not starting which I later fixed by deleting the 856 file use regedit. But the main problem is the map editor. Sometimes it loads up, sometimes it doesnt and when it does, it loads it in SWEDISH. I dont speak swedish, have no idea what the hell anything means I'm trying to find the language interface to change this. Any help is appreciated.

    Thanks.
    Share this post

  2. #2
    Steve64b's Avatar Senior Member
    Join Date
    Jul 2016
    Location
    http://steve.farcry.eu/
    Posts
    1,574
    Check the
    Code:
    %USERPROFILE%\Documents\My Games\Far Cry 4\{YOUR_UPLAY_ACCOUNT_HASH}\EditorGamerProfile.xml
    file & set the Language entries to "english" ?
    Share this post

  3. #3
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,200
    also if your game came from steam check your language setting in steam

    open steam

    select your game right click on it

    select properties .. select language you prefer to use

    some files may need to be downloaded and installed once you re verify your game files at that point

    as your file install may be corrupt

    see this page on steam on how to verify your game files
    https://support.steampowered.com/kb_...2037-QEUH-3335

    if that's where you got your game from
    Share this post

  4. #4
    UBI-Froggard's Avatar Ubisoft Support Staff EMEA
    Join Date
    Oct 2014
    Location
    UK
    Posts
    2,199
    Both great suggestions. Let us know if you need further help @zcubeze
    Share this post

  5. #5
    Steve64b's Avatar Senior Member
    Join Date
    Jul 2016
    Location
    http://steve.farcry.eu/
    Posts
    1,574
    Trying out the patch_cnh Title Update, I had the same problem just now: the Editor wouldn't change the UI Language back to whatever language I set in Ubisoft Connect properties. Changing the EditorGamerProfile.xml didn't work for me.

    Turns out, changing language in the Ubisoft Connect does not set the Language properly in the Windows Registry.

    So, to fix the Far Cry 4 Editor language, clear Far Cry 4 from the Windows Registry by running the REGfile at https://steve.farcry.eu/files/FC4_Steam_StartupFix.zip.
    Running this regfile also fixes the the issue of the STEAM release of Far Cry not starting after you've run the Map Editor.
    Share this post

  6. #6
    Ubi-Litten's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    1,626
    No problem, thanks for getting back in contact and letting us know you have been able to get this query resolved. If you have any other questions or need any further support, please feel free to let us know..
    Share this post

  7. #7

    Got another fix?

    Originally Posted by Steve64b Go to original post
    Trying out the patch_cnh Title Update, I had the same problem just now: the Editor wouldn't change the UI Language back to whatever language I set in Ubisoft Connect properties. Changing the EditorGamerProfile.xml didn't work for me.

    Turns out, changing language in the Ubisoft Connect does not set the Language properly in the Windows Registry.

    So, to fix the Far Cry 4 Editor language, clear Far Cry 4 from the Windows Registry by running the REGfile at https://steve.farcry.eu/files/FC4_Steam_StartupFix.zip.
    Running this regfile also fixes the the issue of the STEAM release of Far Cry not starting after you've run the Map Editor.



    Worked to open the Farcry 4 Game but did not change the map editor language for me, I also use the Steam version and have had this exact issue. Just wondered if you had another fix to throw my way. I'll keep trying to learn enough Swedish in the meantime!
    Share this post

  8. #8
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Posts
    6,278
    Hey Buterbizkit,

    Thanks for reaching out and sorry to hear you are also having issues with language.

    Just to clarify, is your game now opening in English, but just the map editor showing Swedish?
    Share this post