1. #1

    Map Maker for S3

    As part of the History Edition; I should have had access to the map editor for Settlers III.

    I have reinstalled the game about every possible way I can think of with different permissions, etc, but the map editor NEVER works. It only ever gets to the point of 'looking for patches' then says it is not correctly installed. Well Uplay install it all together so why can I run the game and not the editor? I can't find a way to install it seperately? If anyone can help me figure out how to correctly run it I would be happy to hear
    Share this post

  2. #2
    I've found the S3:Amazons CD, unfortunatelly, the editor, despite having standalone setup, would not allow to export maps into .map format (edited and saved maps have other file extension). It says S3 needs to be installed. So this will not work.

    @Ubisoft, are you considering adding S3/S4 map editors? They are part of Mission CDs for S3/S4, but cannot be found in your 'history editions'...
    Share this post

  3. #3
    Ubi-Thorlof's Avatar Anno Community Developer
    Join Date
    Apr 2018
    Hey guys,

    both titles include their map editors which you can access by clicking on "Play" in the Uplay Launcher. This should open a small drop-down menu, letting you choose between launching the game, the config menu or the editor.

    Should you receive an error upon launching the editor then the registry entry didn't succeed during installation. In this case please go to your install folder, go to the golder S3EDITOR and doubleclick the "EditorRegestryKeys.reg"

    Hope this solves your problems
    Share this post

  4. #4
    Thanks a mill, it worked indeed! I've missed the option since I've been launching uplay games using a 3rd party app...

    However, running a regedit was needed, despite "verifying" the installation from uplay app and re-installing.
    Share this post