1. #1

    Campaign Does Not Progress.. Settlers 7 History Edition

    Hi Settlers,

    So I bought the settlers 7 History edition via steam.
    Able to play campaign 1 and 2, however upon completing mission 2 it does not progress to mission 3.
    Tanks for looking into this.
    Share this post

  2. #2
    Ubi-Keo's Avatar Ubisoft Support Staff
    Join Date
    Jul 2017
    Location
    UK
    Posts
    4,793
    Sorry for the late response. Can you please confirm if you are still experiencing this issue? If so could you provide a screenshot of your map.
    Share this post

  3. #3

    Campaign does not progress after mission 3?

    Dear Ubisoft,
    I play Settlers 7 via Uplay, after I finished (today) mission 3 Novice Rising, my campaign does not continue. It shows the final animation, and when I press continue campaign It resets to the start mission.
    regards,
    Share this post

  4. #4
    Ubi-Keo I've experienced the same issue but after the 4th mission.
    Share this post

  5. #5

    I also cannot progress after 'Novice Rising', campaign map resets to 'Dawn of Settlem

    I also cannot progress after 'Novice Rising', campaign map resets to 'Dawn of Settlements' after the cutscene. Did you manage to find a fix?
    Share this post

  6. #6

    Settlers 7 Campaign Reset

    I can't proceed to campaign three after finishing campaign 2 successfully. I bought my Settlers 7 from Steam.
    Share this post

  7. #7
    Ubi-Viral's Avatar Ubisoft Support Staff
    Join Date
    Oct 2015
    Posts
    2,158
    Hi Settlers,

    Could you verify your game files and try again, please - https://support.steampowered.com/kb_...2037-QEUH-3335

    If the issue persists could you reinstall the game and see if the same issue still happens (this may cause game progress to be lost)?

    Thank you and apologies for any inconvenience this has caused.
    Share this post

  8. #8

    cannot progress after level 4

    Hello,

    I have the same issue, but with the trading apprentice level.
    Verified the game files, didn't work. Reinstalled the game, didn't work.

    I can't proceed past level 4. The end movie plays, and then on the map I return to the first level.
    Did you already manage to find a fix for this?

    Thank you in advance for your reply.
    Share this post

  9. #9

    Same here

    Can't get past mission 2, end mission plays and then have to start back at level 1.

    Files have been validated, please don't make me play these missions again
    Share this post

  10. #10

    Also tried a re-install and problem continues

    Also tried a re-install and problem continues
    Share this post