1. #1

    Child of Light resolution stuck

    Hello all! So I redeemed the Child of Light free promotion, however, I can't play it or appreciate the visuals because the resolution is stuck at 640x480, despite running on a R7 2700x and GeForce GTX 1070.

    Can this be fixed, or am I stuck playing a broken game?
    Share this post

  2. #2
    UbiDork's Avatar Ubisoft Support Staff
    Join Date
    Dec 2018
    Posts
    2,337
    Roccondil1: Hi there! Can you please tell me what happens when you attempt to change the resolution in game?
    Share this post

  3. #3
    Absolutely nothing. Alternate resolutions are unavailable, the selection arrows are greyed out, 640x480 is the only setting.

    I've found that I can set the game to windowed mode, and then maximize the window: that changes the game to a larger resolution, though the resolution setting still cannot be changed directly. But when attempting to use borderless window or fullscreen mode the resolution is stuck at the smallest possible resolution and the setting still cannot be changed.

    (Could this be a possible cause of issue? The monitor I am using is connected via HDMI, however, the HDMI port on the monitor itself is not properly working so while I still get the expected quality video signal to the monitor, the return signal from the monitor with automatic monitor settings and metadata [like what monitor it is, etc] is not being sent back to the GPU, so I had to manually set up the monitor profile on the video settings myself, instead of it automatically setting itself up.)
    Share this post

  4. #4
    UbiDork's Avatar Ubisoft Support Staff
    Join Date
    Dec 2018
    Posts
    2,337
    Roccondil1: Thanks for that information, I appreciate having that update. With that all in mind, it could be that there is an issue with the HDMI, however I think we can focus on the game as the issue at this time. To get this resolved, let's try a few steps! Could you please try verifying your Uplay PC game files and try running Uplay PC as an Admin?
    Share this post