1. #1

    [The Settlers V] Graphics blocked in medium/low

    Hi everyone !

    My problem is on the game "the settlers 5 hystory edition". Some of its graphics like shadows or terrain quality are blocked at medium or low level (or even disabled). This is annoying especially I have an excellent computer, the game runs at more than 400 fps.

    Thank you in advance for your answers!
    (Sorry for the possible language mistakes, I'm French)

    I start again in French just in case / Je recommence en français au cas où !
    Mon problème est sur le jeu "the settlers 5 hystory edition". Certains de ses graphismes comme les ombres ou la qualité du terrain sont bloqués au niveau moyen ou faible (voire même désactivés). C'est gênant surtout que j'ai un excellent ordinateur, le jeu tourne d'ailleurs à plus de 400 fps.

    Merci d'avances pour vos répondes !

     1 people found this helpful
    Share this post

  2. #2

    Same Issue

    Hi Guys

    I have the same issue. I can change the rsolution but I cannot select options for things like shadow details. I'm running a good spec PC i9 9900k and RTX 2080 with all the latest drivers. When I launch the game on the max settings I can select the text isn''t aligned correctly i.e. when hovering over a mine it shows the available resources at a different location on the screen. Really annoying! Any suggestions welcomed.
    Share this post

  3. #3
    Ubi-Karl's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    3,901
    Hey guys,

    Thanks for reaching out to us and I am sorry to hear about this.

    In order to resolve this, if possible, try switching between graphic card adapters, and try using an alternative one to see whether issue persists.
    Share this post

  4. #4

    I created a patch

    This issue is caused by the game checking your graphics driver version and greying out the option if the last for digits are between 4000 and 5999.

    I have created a patch that fixes the issue by changing the numbers the game checks for (to some value that won't ever exist as a real version)

    Since I don't want to upload the whole exe file The patch an ips patch and you will need lunar ips to apply it.

    How to apply the patch:
    1. Dowload Lunar IPS: https://fusoya.eludevisibility.org/lips/
    2. Dowload The Patch: https://keinniemand.my.to/index.php/s/tTw5KwwxY2snYRZ
    3. Start Lunar IPS and click on apply patch
    4. Select the Patch you downloaded
    5. Select the Original Exe file witch is in <install directory>\bin\SettlersHoK.exe
    6. Click Ok

    This should fix the issue. However I'm not 100% sure if it works since I'm german and I don't know if the exe file is diffrent in the english version. It will work as long as the file is the same.
     3 people found this helpful
    Share this post

  5. #5
    Ubi-Viral's Avatar Ubisoft Support Staff
    Join Date
    Oct 2015
    Posts
    3,151
    Originally Posted by KeinNiemand Go to original post
    This issue is caused by the game checking your graphics driver version and greying out the option if the last for digits are between 4000 and 5999.

    I have created a patch that fixes the issue by changing the numbers the game checks for (to some value that won't ever exist as a real version)

    Since I don't want to upload the whole exe file The patch an ips patch and you will need lunar ips to apply it.

    How to apply the patch:
    1. Dowload Lunar IPS: https://fusoya.eludevisibility.org/lips/
    2. Dowload The Patch: https://keinniemand.my.to/index.php/s/tTw5KwwxY2snYRZ
    3. Start Lunar IPS and click on apply patch
    4. Select the Patch you downloaded
    5. Select the Original Exe file witch is in <install directory>\bin\SettlersHoK.exe
    6. Click Ok

    This should fix the issue. However I'm not 100% sure if it works since I'm german and I don't know if the exe file is diffrent in the english version. It will work as long as the file is the same.
    Thank you for providing this suggestion. If this does not work please let us know and we will look into this further with those affected.
    Share this post

  6. #6
    So... I've had the same problem for almost a year now, with no solution and patch from Ubisoft side. @KeinNiemand Your post gave me some hope, but unfortunately this does not work for me.

    I'm using steam version of the game and after applying patch steam gives an 51 error code - Unable to launch. Running it from game folder doesn't work either.

    Please for the love of God Ubisoft do something.

    @Ubi-Karl
    what do you mean by "switching between graphic card adapters". I have only one graphic adapter and it's more powerfull than needed for this game.
    Share this post

  7. #7
    I might be able to create a patch that works for your version if I can get the (unpatched) exe file of your version. I don't know if I can change some language setting to get your version (I have the uplay version) or if it's becouse you have the steam version otherwise you would have to upload it somewhere and send me the link. I can't create a patch without the exe file of whatever version you are using since there are apperently diffrences beteween diffrent versions.
    Share this post

  8. #8
    @KeinNiemand
    I've sent you links for my steam version executables in a private message. If you get it patched, you can post patch here, maybe someone will use it too. Thank You for your help.

    EDIT:
    @Ubi-Viral
    We've tried everything to fix it ourselfs. But had no luck. Please look at this problem asap, since it concerns a lot of potential playerbase. For me it's unplayable without those options, since for example Ice textures are black...
    Share this post

  9. #9
    Ubi-Viral's Avatar Ubisoft Support Staff
    Join Date
    Oct 2015
    Posts
    3,151
    Originally Posted by Heksyl Go to original post
    @KeinNiemand
    I've sent you links for my steam version executables in a private message. If you get it patched, you can post patch here, maybe someone will use it too. Thank You for your help.

    EDIT:
    @Ubi-Viral
    We've tried everything to fix it ourselfs. But had no luck. Please look at this problem asap, since it concerns a lot of potential playerbase. For me it's unplayable without those options, since for example Ice textures are black...
    I have checked with the Dev team for this issue and this is a problem they are aware of however it isn't a problem that can be easily resolved, however, potentially using onboard graphics (Intel HD) on systems that may have this capability could allow access to higher graphical options.

    Could you try using the integrated graphics to see if it works?
    Share this post

  10. #10
    Most Bioses (including mine) is disabling usage of integrated graphics when any external Graphics card is placed, not counting that Tower PCs don't have CPU's with integrated graphics. Taking out external graphics card just for this game to run (it supposed to run on new systems... sigh) seems like an unresonable solution.
    Share this post