🛈 Announcement
Greetings! Assassin's Creed forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game.
  1. #1

    No one attacking the dr in boston for homestead mission on switch

    Okay all i got something weird.

    Nintendo switch assassins creed 3 up to date

    I started the happy expectations homestead mission. And on my way to Boston I did the homestead mission about learning bowling. Upon arriving in Boston and talking to The Apprenticehe instructed me to go around the corner and find the doctor.

    Every time I approach the doctor the action music starts but everybody stands absolutely still and nobody attacks anybody.
    Bumping into people forcibly or riding my horse through them, even calling in Assassins to beat them up does nothing. ( except end the mission because the wrong weapon was used when my assassins killed one of the attackers)

    This glitch remains after restarting, or ending and restarting the memory. Even after quitting the memory and completing a couple of assassin missions in Boston and coming back it still didn't work.

    Have yet to turn off the game completely remove it and see if it works after that but I thought I'd let the Community weigh in first

    Thanks for your help all hope to get this figured out as I want to get my Homestead missions completed
    Share this post

  2. #2
    This issue was resolved after closing out the game re moving the game cartridge reinserting it into the switch and restarting the game

    Another interesting fact was that on the first time I approached the fight with the doctor his legs were half in the ground and half out of the ground he was kind of clipped into the street. I don't know if this was the cause for the issue until stopping and restarting the game but it was. Something of note.
    Share this post

  3. #3
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Posts
    7,058
    Hey Ceephisgmr,

    Apologies for the delay in getting to you.

    Thanks for letting us know you resolved the issue for yourself.
    Share this post