I ran into this same bug in Far Cry 5 but the work around there was to disable steam's controller support and allow Uplay's to kick in. However, this doesn't work in New Dawn, since if I disable Steam's controller support, the game doesn't respond to the controller at all.