1. #1

    Starlink.exe cannot run under a virtual machine

    Hello!
    Recently i tried to launch Starlink using NVIDIA GeForce Now Beta, and you guessed it, that didn't work.
    Every launch attempt ended up with the same error - "Starlink.exe | Sorry this application cannot run under a virtual machine"
    Can you give any comments - why? Any possibility of fixing this in the future?


    After googling about this error, it seems that it is rare in general and the only "fix" for it from user side - to disable Hyper-V and some NET. 3.5 features in system, but because few people have admin access to GeForce Now servers (at least i hope only intended personnel have), that is not possible solution.
    The main reason i ask and "strange part" is - even though Starlink is not listed as "officially supported" title in GeFNow, i've tried a lot of different "not supported" titles that worked fine, and this is first game with this problem encountered.
     3 people found this helpful
    Share this post

  2. #2
    I get this same error message but I'm not using GeforceNow. I'm trying to run this on my own physical PC, no VM involved. A thread on Steam forums suggests that disabling virtualization in UEFI might solve the issue but that's an essential feature of my PC that I do use for other stuff. Frankly, it's ridiculous that the game is not able to run because of this. I opened up a support ticket with all my config details and screenshot. I'm eagerly waiting for a response.
    Share this post

  3. #3
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,050
    Hey guys. Just to clarify, we do not officially support GeForceNow. We apologize for the inconvenience.
    Share this post

  4. #4
    Could you resolve the problem with having Hyper-V enabled?

    I don't want to have to restart to change my BIOS settings just to play your game.
     3 people found this helpful
    Share this post

  5. #5
    Ubi-Woofer's Avatar Ubisoft Support Staff
    Join Date
    Aug 2019
    Location
    United Kingdom
    Posts
    2,866
    Originally Posted by xcyoteex Go to original post
    Could you resolve the problem with having Hyper-V enabled?

    I don't want to have to restart to change my BIOS settings just to play your game.
    Hey xcyoteex, would you mind clarifying if this issue still persists for you even now?

    If unable to run the game on your PC even after disabling Hyper-V, we'd like to see your MSinfo and DxDiag files to investigate further. Please submit these to us via a support case on our website, and drop the case reference number in a reply here so that I can take a look. Thanks!
    Share this post

  6. #6

    Starlink Cannot run under a Virtual Machine (Straight PC Windows 10)

    I decided, after reading other posts, to make my own being this is straight Windows 10 Pro off the desktop from the Ubi Launcher. I'm NOT using nVidia gForce Now. I am not running in a virtual machine, though there IS one configured on my system for testing other programs (I DO test software for people and NEED this machine that resides on an entirely different hard drive). I have tested various settings, trying to get this game to work... I only JUST purchased it and have not gotten it to run ONCE yet. On launch the error "Sorry, this application cannot run under a Virtual Machine." instantly pops up and execution haults! I have even gone as far as going into Windows 10's security settings and turned off the Core Isolation Memory Integrity settings which 'should' have stopped isolating any and all programs in a virtual state of memory on execution... didn't help. Uninstalled Avast Antivirus with the thought 'maybe it's use of virtual isolation testing is triggering this error...' nope... Gone so far as to uninstall and disabled ALL antivirus / malware protections to find it is none of these that are throwing this 'error'.

    From what I have been reading, the only conclusion is there is code that is detecting the virtual machine software is installed and or hardware is active even though the game is not running within the software, it is refusing to run because it detects the needed software and or hardware turned on.....

    How is someone supposed to play this game in this situation? Turning off the hardware and / or uninstalling the needed software every time is unacceptable!

    ------------------
    System Information
    ------------------
    Time of this report: 11/20/2019, 12:48:44
    Machine name: MEMORYALPHA
    Machine Id: {DFB10772-6321-4B0B-B3DF-80CD8BA4513C}
    Operating System: Windows 10 Pro 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
    Language: English (Regional Setting: English)
    System Manufacturer: System manufacturer
    System Model: System Product Name
    BIOS: 5220 (type: UEFI)
    Processor: AMD Ryzen 7 1700 Eight-Core Processor (16 CPUs), ~3.0GHz
    Memory: 16384MB RAM
    Available OS Memory: 16316MB RAM
    Page File: 7075MB used, 17432MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 12
    DX Setup Parameters: Not found
    User DPI Setting: 96 DPI (100 percent)
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    Miracast: Available, with HDCP
    Microsoft Graphics Hybrid: Not Supported
    DirectX Database Version: Unknown
    DxDiag Version: 10.00.18362.0387 64bit Unicode


     3 people found this helpful
    Share this post

  7. #7
     1 people found this helpful
    Share this post

  8. #8
    XCyoteex, exactly WHAT dot net 3.5 features did you have to disable because even disabling all Hyper-V, Virtual Machine features (and I NEED these for other programs that I work with to function for beta testing!!!) that still didn't get this game to work! I've tried blanket disabling 3.5 and it still came up unable to run this game... I started my own thread on this as I'm not playing this other than straight Windows 10 Pro. I'm not using nVidia GeForce Now so we have different threads for this reason... but sharing notes won't hurt on this! (No sense re-creating the wheel if someone made it already...)
    Share this post

  9. #9
    Update: I have submitted a support request for this. Reference number for the support request is 10165041.

    And sorry for the frustrated rant in the request... After uninstalling all the virtual machine components to test only to find the game STILL came up with 'Sorry, can't run in a virtual machine'.... I really got frustrated. Yeah, no virtual machine parts are installed and it STILL isn't running now! Hyper-V, Virtual Machine, all of it was removed. All the drives.... still not running!
     3 people found this helpful
    Share this post

  10. #10
    UbiCovah's Avatar Ubisoft Support Staff
    Join Date
    Jun 2018
    Posts
    1,114
    Hey, FalconGrey!

    Apologies for the delay. If you are still experiencing this issue, please reopen/update case 10165041 so that a specialist can help diagnose the issue.

    Thanks
    Share this post

Page 1 of 5 123 ... Last ►►