1. #1

    Tyranny of King Washington - broken savegame!

    Well, let's be honest here, ToKW has a LOT of bugs, but most of them can be ignored. So what if the Danish Naval Axe disappears from my inventory whenever I unequip it? It's not that great anyway. And I can certainly ignore the way the Club Challenges from the main game keep popping up. But this is just... game-breaking.

    I was trying to complete the Citizen Missions in Chapter II: Betrayal - Boston, ya know? I'd done most of them, but the 'Save civilians from wolves' goal proved impossible since only one spot in the city spawns wolf-attacks, and the attack had stopped spawning there. Even flying halfway across town and back again failed to make another attack turn up. So I quit the game, hoping that they'd start spawning again once I loaded my save. However, once I did, I found that the game had simply FAILED TO SAVE 80% of the stuff I'd done! The main missions were still there, sure, but EVERYTHING else had been lost. All the chests I'd opened, all the weapons and upgrades I'd acquired, even my supplies and ammunition - all gone, everything reset to ZERO, along with all the Citizen Missions. Did I mention that I'd cleared all of them save that one last Wolf Attack that refused to spawn? Yeah, they're all back to zero now. ZERO. I'd have to start all over again. Assuming of course that the Wolf Attacks didn't stop spawning again.

    I can tolerate minor bugs and glitches, sure, but THIS is just INTOLERABLE. It makes me wish I'd gotten the game on a physical disc instead of digital just so that I could throw it out my window in disgust! And this is a game that is SEVEN BLOODY YEARS OLD!
    Share this post

  2. #2
    I'm experiencing the same bug. Especially frustrating after the 60 hours I've put into the main game trophies. I tried playing through some of this TKW and putting the PS4 in Rest Mode instead of powering down. I'm hopeful that will keep the game active when I turn the PS4 back on. I'll follow up tonight if it worked.
    Share this post

  3. #3
    No hay respuesta? Este es un error grave. Tengo exactamente el mismo problema. Y en el episodio 3 me pasa lo mismo q a el pero con la mision de defender a los civiles
    Share this post