1. #1

    Unable to download any game on uplay. Not allocating the proper disk space.

    Hello there, I've had this issue for a couple of weeks now and I've sent in a support ticket over a week ago but I still haven't received any help what so ever. It started off with Odyssey when I bought the season pass, the game wouldn't finish downloading and kept saying it failed. So i tried uninstalling the entire game and reinstalling but now it only goes up to 54% completion before it fails again. I then decided to uninstall Origins (which was playing fine before I uninstalled) to see if it was game specific but now that doesn't even get past 17GB downloaded.

    Everything else downloads, such as other applications and steam games so this is u play specific. I've tried installing it so many times, changing folders, disabling anti virus and firewall and yet the same thing happens. I've also managed to work out the issue but have no way of knowing how to fix it. By this I mean the the game initialises the download it's not allocating the entire amount of space needed. So when it says 90gb is needed for AC Odyssey it only allocates 50Gb. And I know this because once it starts installing it has only taken up a much smaller amount on my hard disk.

    I have even bought a new hd (ssd) drive) to see if that would work but the same thing occurs, I'm honestly lost. I've paid doe something that I cannot even use and it's not good enough. Any help would be appreciated.
    Cheers
    Share this post

  2. #2
    Ubi-Trippn's Avatar Ubisoft Support Staff
    Join Date
    Nov 2016
    Posts
    1,873
    Hi RagnarHawke Have you tried running Uplay as an administrator?

    go to the installation directory, by default the location is:
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher
    1. Right click Uplay.exe
    2. Select properties
    3. Switch to the compatibility tab and tick run this program as an administrator.
    4. Click Apply and then OK


    Then try the download again
    Share this post

  3. #3
    Hi there, I've tried running the program as an administrator with admin rights but the same issue still occurs. The files cannot be verified when I begin installation either, but whether that's normal due to it not being fully installed. So what seems to happening is the launcher is not allocating all the files needed to download the game/s which is why the download speed plummets at 54% on Odyssey or 20% on Origins etc... because there is nothing to download: I was able to play Odyssey fine before this, but as soon as I bought the season pass which then had to be downloaded it wouldn't work properly. And so now here we are.

    Here are a list of solutions I have tried

    Running the program as Administrator
    Uninstalling and reinstalling Uplay on a different drive
    Uninstalling and reinstalling Odyssey, Origins etc on a different drive/folder
    Throttling my download speed to a lower speed
    Flushing my internet DNS
    Changing my DNS
    Resetting my network both on the modem and in windows


    but this seems to be isolated to u-play specifically

    https://bn1303files.storage.live.com...652&height=929

    As you can see if this image can be seen, Odyssey is a 90-100GB game and yet it's only taking up around 50-54GB on my E-drive after allocation. The same goes for my C-drive.

    As you can also see in this second image, after the allocation of Assassins Creed Origins the whole file size is only 18.1GB.

    Share this post