1. #11
    Neither I can unlock Botanica DLC club rewards and i have purchased dlc pack long ago before sunkene treasures. ...
     1 people found this helpful
    Share this post

  2. #12
    Thanks FurryBeast. I am looking out for any more bugs. If you find anything else please do post here to my thread. I will keep updating this thread I started if I find anymore bugs as well.

    I think I found another one where all ships are drifting away from their original position over time. I had this happen to a few of my clippers in the new world and some of my frigates too. While in the old world my tankers where drifting around on their own and some of my other ships. And they where not in the way of other ships passing by or coming to moor to trade. I did see someone else mention in the forum or union about this bug. So it is likely the possibility that this bug is happening. I will keep a closer eye on my ships and record any videos if I mange to catch it as it is happening. I think the ship collision avoiding system the devs put in ships to prevent them from clipping each other as they pass each other might be bugged. I will further investigate this. IF you could as well. I would appreciate it.

    Thank you.

    Best,
    Feruda
    Share this post

  3. #13
    Same thing with me. Exactly the same issue I have. As you seen in my video above. Good to know this isn't just me with the issue.

    I also heard rumors of game saves being held ransom if you played the free week or tried the one month Uplay Plus trial.
    Someone said that after it was over they could not access the saves they had. Or revert to the previous saves before that.

    And one of my friend who tried to buy the season pass today was forced to accept the one month trial for Uplay Plus in order to
    be able to buy the Season Pass. I don't know if it is now required to have Uplay Plus in order to buy Ubisoft games and their DLCs or if it's a bug.

    Please let me know if you find anything. Or have fellow players who ran into this as well.

    Best,
    Feruda
    Share this post

  4. #14
    Good Lord the game is broken! Thank you for posting and verifying you have the same issue BugmanKF. Looks like the latest update has broken the game. Hopefully they will do a patch soon and hopefully that will smush the pesky bugs.
    Share this post

  5. #15
    Thank you for verifying MartulaZ Hopefully the developers will notice this soon and come up with a patch.
    Share this post

  6. #16
    Same here Anica. Good to see you again btw. I hope your adventures in ANNO 1800 are pleasant since we last spoken. Yeah I bought the DLC when it came out the first day. I immediately got the Season Pass. I am absolutely enjoying the DLC, however all these pesky bugs need smushing. Where's the RAID spray when you need it? Lol.
    Share this post

  7. #17

    Anno 1800 - Botanica Club Rewards not working

    Botanica DLC Club Rewards still not working[IMG]<blockquote class="imgur-embed-pub" lang="en" data-id="a/LkoOBBM"><a href="//imgur.com/a/LkoOBBM"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>[/IMG]

    https://imgur.com/nTyjhin
    Share this post

  8. #18
    I have club rewards now after update but have still following bug:

    Hedge Mage, Topiary Avenue and Garden rewards from quests and Botanical Exhibition's wont show up in pathway ornaments from Zoo, Museum and Botanical Garden.
    Share this post

  9. #19
    Really Steely700? Another bug??? I have not run into that yet. I have not yet used those ornaments. Probably won't for a good while since I am still working on my city. Transitioning to Engineers now. I plan to build proper zoos, museums, and a garden later. If I run into any of those bugs you specified then I will update to this thread as well.

    Thank you for the information.

    Also if you could please try to provide screenshots and or better if you could provide videos and upload to YouTube and bring those videos to my thread here like how I did with my videos. That would be great proof right now for the developers to see there is this issue you mentioned.

    Best,
    Feruda
    Share this post

  10. #20
    I finally got them working, it's kind of weird how it works, you have to go for this 3 blueprint in your warehouse first and click on it and then they will appear, don't understand such a weird design choice.

    But another bug I found is when you have a group of ships protecting a convoy to another region and they attack some one, they stop following your trade ship.
    Share this post