1. #1

    PC performance: please share specs, settings, fps & resolution

    Hey guys, just curious how it's running for the rest of you.

    My PC: Vega 56, Ryzen 1600x, 16gb ram @ 1440p

    It seems like settings don't make much difference at all as far as frame rate goes for me. CPU is like at 35% most the time while my GPU is around 95%.

    I'm getting like 45-60 fps...very inconsistent and frustrating.

    What about you guys?
    Share this post

  2. #2
    Ancient i7-980X, watercooled and OC'ed 1080Ti, 48GB of DDR3 RAM.
    Running 3440 x 1440 at around a similar 45-60FPS to the OP.
    I dont really expect any better, its pretty much around the usual performance I get out of detailed open world games.
    Share this post

  3. #3
    Originally Posted by LiquidPinky Go to original post
    Ancient i7-980X, watercooled and OC'ed 1080Ti, 48GB of DDR3 RAM.
    Running 3440 x 1440 at around a similar 45-60FPS to the OP.
    I dont really expect any better, its pretty much around the usual performance I get out of detailed open world games.
    I would rather be able to turn down settings than to play at higher settings and the frame rate jump around. I hope they optimized it a bit better. If they don't it will be my last pre order for sure.
    Share this post

  4. #4
    Share this post

  5. #5
    Where are you guys? I know they're are PC players out there
    Share this post

  6. #6
    beta/demo ran better than tech..pre-alpha, 50-60 fps vs maybe 35 fps
    but considering how everything looks so bland and how lod is like 50m at most i still don't see where all the resources are going, ohh wait i know dreaded battle eye+denuvo
    Share this post

  7. #7

    Specs

    I'm running I7 8700k 1070ti 16gb

    1440p 130 upscale

    Ultimate.
    40 -43 frames
    Share this post

  8. #8
    All settings are set to ultra. FPS are 60 with sync.



    I hope this is enought.
    Share this post

  9. #9
    Halli-SPARTA's Avatar Member
    Join Date
    May 2006
    Location
    FOB next to LZ
    Posts
    83

    Runs fine on an old system

    i7 2600k @ 4.4
    16gb ddr3
    Gtx1070sc 8gb
    2k res
    getting average of 58 fps 95% gpu, 50% cpu
     1 people found this helpful
    Share this post

  10. #10
    Running old Dell T5500 system with 9y old processor Xeon X5650 6core/12threads, 24GB DDR3 ECC RAM, RX580 8GB and i get around 40 FPS on ultra settings wich is weird. I didnt expect this. Game is smooth even on this frames, no lag or stuttering at all. On high i get 55-70 FPS.
     1 people found this helpful
    Share this post

Page 1 of 4 123 ... Last ►►