1. #11
    Shosui's Avatar Junior Member
    Join Date
    Sep 2019
    Posts
    19
    Meanwhile here I am running on average 50 FPS with 2k res on custom medium/high settings. Only dip to high 30s with tons of explosions and other particle effects going wacky, and can push 70 in exploration. It certainly needs to be optimized better overall, but it's not horribly bad.

    i7-4790k @ 4.4 GHz
    16 GB RAM @ 2400 MHz
    GTX 970 (the 3.5 GB meme) with
    GTX 650 Ti as the secondary (for more PhysX meme-ing)
    Share this post

  2. #12
    I have a r5 2600x / rtx 2060 and get pretty consistent 60+ fps on all Ultra (w/ textures on ultimate) . very satisfied
    Share this post

  3. #13
    I managed to get it running well by disabling SLI completely. On ultimate, 1080p and getting fairly stable 60fps. Dips in some lighting and weather conditions and some areas of the map slow down slightly. When fighting the behemoth it tanked to between 30-45 but I think that's to do with some of the particle effects because it zipped back up when the thing was destroyed.

    Titan X Pascal, 6700k.

    Ok performance so far for an early build.
    Share this post

  4. #14
    Im running a 17 8700k and GTX1080 in Ultra. In game the resolution in game is NOT in 1080P in the settings it has the resolution setting grayed out. I need to know how to get the resolution set where it belongs
    Share this post

  5. #15
    i7 8700k with rtx 2060 32g ram playing it on ultra 2k and i 60 to 50 fps and it looks fantastic nice work
    Share this post

  6. #16
    It seems if I have multiple monitors the game locks me into a low resolution. When I turned off the second monitor I was able to change the resolution.
    Share this post

  7. #17
    I haven't been able to find this issue anywhere so it might be my setup.
    I'm having trouble getting it to run on my main GPU.
    I have an RTX 2080 as my main GPU and a GTX 1080 in another space. The GPUs output to different monitors yet the game is running on 1080 and displayed on the monitor my 2080 is connected to. I've tried changing the usage in the nvidia control panel but the game still runs on GPU 2.

    Otherwise, game runs great! And plays very nicely!
    Share this post

  8. #18

    Optimization makes me worry (((

    i7-6700k
    1080 Ti 11Gb
    32Gb DDR4
    Monitor 21:9 2560x1080

    Оn ultra settings, the game works disgustingly, the situation is very better at very high settings and almost stable at high, but this does not meet the stated requirements, I hope that they will correct it for the release.
    Share this post

  9. #19

    My Specs

    Current Setup:
    Ryzen 5 2600X 3.6 GHz
    AMD Radeon RX 580
    16 GB DDR4 RAM

    I tried streaming the game from the PC port via Streamlabs OBS. MAJOR frame drops, dialogue clipping everyWHERE, and constant freezing, even on lowest settings! I turned off browsers, and only had the streaming software, Breakpoint, and my bots and other stream software open. Idk what's up, and usually I can broadcast a game fine, but I hope within this month, the PC port can be more optimized for streaming on Twitch from PC.
    Share this post

  10. #20
    My setup:
    i9-7900X OC 4,7GHz, 128 GB G.Skill TridentZ DDR4 Memory 3866MHz, MB Asus ROG Rampage VI Extreme, Asus ROG Poseidon 2xGTX1080Ti SLi 1709MHz, M.2 Samsung 960 Pro 2TB, M2 Samsung 960 PRO 1TB, Corsair H115i, Corsair AX1500i. Display 3x BenQ XL2420T 120Hz.

    Ghost Recon Breakpoint all settings on Ultra,Resolution Scale 200%, 1080p, 1920x1080, 120Hz FPS: 70 also tried DSR (2715x1527) with about same result. Dont have 4K monitor or 4K tv.

    I did see that SLi were somewhat working, with #1 card having 100% load, #2 card having 35% load.

    Loving the game! Looks beautiful and loved the new RPG elements. Preordered Ultimate edition on both PC and Xbox

    Best Regards

    DaZleeper
    Share this post