1. #41
    V4rdyn's Avatar Junior Member
    Join Date
    Apr 2019
    Posts
    11
    Any changes in the past few days?
    Ubi is still holding 1€ in reserve, no invoice, no access, and I'm currently reluctant to try again.
    Share this post

  2. #42
    Nope, I still have £12.99 held in reserve with no access to UPlay+ Customer Support just keep on saying no update, please refer to this post on the forum. It verges on the ridiculous. One week on and still the same.
    Share this post

  3. #43
    Just got emailed from ubisoft about uplay+.. i gave it a shot and tried to pay again .. same story .. #404 error .. soo 4 attempts .. once got money back ..
    Share this post

  4. #44
    Same here in Czech republic. Still 404
    Share this post

  5. #45
    Uspray splash still now working. 6 times paid, only once got 1eur back. Greatness awaits.
    Share this post

  6. #46
    Well I might as well jump in, Australia here and If I try so sign up from Uplay I get the not the right store error for your region and If i try there webpage Get the 404 error, see below

    https://store.ubi.com/on/demandware....cationResponse

    I mean how hard is it.

    And now I have 4 outstanding authorizations on my account

    12 SEP POS AUTHORISATION UBISOFT PARIS FR Card Used **** $1.00 (this one was card)
    11 SEP POS AUTHORISATION UBISOFT PARIS FR Card Used **** $1.00 (this one was paypal)
    11 SEP POS AUTHORISATION UBISOFT PARIS FR Card Used **** $1.00 (card)
    11 SEP POS AUTHORISATION UBISOFT PARIS FR Card Used **** $1.00 (paypal)

    can anyone from ubisoft answer this for us please
    Share this post

  7. #47
    Same here, I tried to subscribe to uplay+ to try the breakpoint beta at 3 different times but always got an error. One week later my bank account still shows 3 euro is being held in reserve?
    Share this post

  8. #48
    So I still see there's no progress here. Can't access, can't cancel, can't do anything. I'm getting ready to tell my bank not to accept any withdrawals from Ubisoft
    Share this post

  9. #49
    I was able to get Uplay+ with a new Uplay Acc and the same Card. Seems like there is a big error in the Database that some Users just can't subscribe.

    Besides that I am still waiting for my money of 3 failed attempts: 1x 15 Euro, 2x 1 Euro. The ignorance of Ubisoft is a slap in the face. It's been 1,5 weeks now and they still haven't fixed this.
    Share this post

  10. #50
    404 is gone for me, but payment fails in 3 of my browsers and in the Uplay client
    Ordered something from another website without credit card issues, so it's not on my side
    Share this post