1. #1

    Rocksmith Sound Glitches and stops working on Dell Gaming Laptop.

    I just got a new Dell G7 Gaming laptop and Rocksmith isn't liking it.


    The problem I'm having is my sound will die out after playing for any random amount of time.. When it dies, the game stutters and makes this weird robotic sound. Then it stops registering any sounds from the guitar.. Sometimes it happens after 15 minutes. Sometimes 1 over an hour. If I unplug the real tone cable and plug it back in, sound comes back.

    I'm using the analog out on the laptop and the cable is plugged right into the USB port on the laptop.

    - I've played around with ini settings and none seemed to fix it.
    - I dont think it's a performance issue because this laptop is crazy fast and runs games like Battfield 5 smooth as butter.
    - I have two real tone cables and they both have the same issue, so I dont think it's the cable.
    - I've used rocksmith on at least 3 other computers in the house and havent had this problem.


    Im guessing there's something about the Game and this Laptop that isnt jiving.


    Any ideas?
    Share this post

  2. #2
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,706
    First go to the laptop manufacturer's website and get all the updates for your laptop.

    2nd, make sure any background apps/tasks are closed and not using resources.

    3rd, gaming laptops usually have switchable graphics. Make sure the Rocksmith game is using the high powered graphics card and not the CPU graphics engine. This will be a setting somewhere in the graphics card settings.

    4th, always play with the laptop plugged into wall power. Most laptops will not use the high powered graphics card unless it is plugged into wall power.

    If you still have issues after all that, let us know.
    Share this post

  3. #3
    Yup.. laptop is definitely on AC power.

    Itís using the nvidia rtx graphics card as I manually set it. It was defaulting to the intel graphics. All drivers and bios are up to date. Running latest windows 10 1903 with all windows updates.

    Iím tempted to drive the factory restore as mentioned in the other dell post. I just fear that the issue would reappear once everything updates (drovers, windows, etc)


    I keep at it. Itís a hard thing to troubleshoot because it seems totally random, so every time I try something to fix it, I end up playing for awhile.

    I guess the upside is itís forcing me to practice constantly to see if the issue is fixed
    Share this post

  4. #4
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,706
    I use my Dell gaming laptop all the time to play Rocksmith. I've never had any kind of issue with it.
    Share this post

  5. #5
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,706
    Re-reading your OP maybe it is a USB power issue. Make sure your power configuration is setup to never turn off USB power.
    Share this post

  6. #6
    been playing with this awhile.. re-installed entire laptop and everything and having the same problem. For some reason the option to turn off USB Suspend is not available in power settings on this laptop. But in Device manager, I set all the USB Hub and Root Hub devices to not power down. Didnt seem to fix it.

    But now i'm the sound doesnt totally cut out... it just turns all garbled and robotic sounding after a few songs and I have to restart the whole game.

    Ill keep playing with it I guess.. I really would rather not have to use my old computer to use this one program
    It's the 17" version of this:
    https://www.dell.com/en-us/shop/cty/...05066871693014
    Share this post

  7. #7
    Ubi-Redbeard's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    3,681
    Originally Posted by CrazeD_Z06 Go to original post
    been playing with this awhile.. re-installed entire laptop and everything and having the same problem. For some reason the option to turn off USB Suspend is not available in power settings on this laptop. But in Device manager, I set all the USB Hub and Root Hub devices to not power down. Didnt seem to fix it.

    But now i'm the sound doesnt totally cut out... it just turns all garbled and robotic sounding after a few songs and I have to restart the whole game.

    Ill keep playing with it I guess.. I really would rather not have to use my old computer to use this one program
    It's the 17" version of this:
    https://www.dell.com/en-us/shop/cty/...05066871693014
    Hey,

    If the issue is still persistng, can you create a support case and submit your system files? A guide to doing so can be found here.

    In the meantime, let us know if you manage to resolve the issue
    Share this post

  8. #8
    Hello.

    So I went ahead and made a support case. One of the suggestions was to disable all services and then try the game out.. Then try to determine which service may be causing an issue.

    So I did disable all services, rebooted windows, and was able to play for an hour without experiencing the problem. This is much longer than I've been able to play recently. So it's likely one of the services is causing an issue with the game. So now the hard part is determining which service is the problem. This computer has lots of services from Dell, Nvidia, Mcafee, Killer NIC, etc running. This might take some time

    Thanks again though!
    Share this post

  9. #9
    I've been having this same issue after having the game perform perfectly for years. I, too, have a Dell gaming laptop and I've followed the suggestions on this thread. My guess is that the game may be having issues with newer nvidia video card drivers
    Share this post

  10. #10
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,706
    Some times the drivers from Nvidia don't work with switchable graphics systems, like Dell gaming laptops.

    Try the Nvidia driver directly from Dell.
    Share this post