1. #1

    Cannot get access to New World

    Hi everyone I've run into an issue when when trying to venture into the new world, basically I can't get access to it!

    I've watched a couple of You Tube videos and it seems you can have access as soon as you advance to your first artisans. As soon as you do, you have access to expeditions and a have the ships wheel icon appear next to the Quest, Warnings etc side bar. Though I don't have this ships wheel icon after advancing to the artisans.

    I'm now up to a quest called a "Mission to a new World" which asks you to complete the New World Expedition, but I can't seem to?

    Is anyone able to help?
    Share this post

  2. #2
    MOD_Freeway's Avatar Anno Moderator
    Join Date
    Oct 2015
    Location
    Mainz, Germany
    Posts
    48
    Hello Herz_01,

    basically you just have to make expedition "Mission to a new World"
    if you click this quest you'll automatically guided through the menu.
    select a ship and lets go - it takes a bit time until you reach the new world but you'll be updated from time to time by the capitan


    Best,

    MOD_Freeway
    Share this post

  3. #3
    Hi Mod_Freeway,

    Thanks for your input, am I missing something really obvious, I can't seem to do your suggestions?

    If I press the top section of the quest "Mission to a new world" it opens up details about the quest. If I press the lower section of the quest "Mission to a new world" it opens up the world map, nothing about starting expeditions shows up.
    Share this post

  4. #4
    Is anyone from Ubisoft able to assist? I've posted the issues on a community forum on Facebook but got no answers that solved the issue.
    Share this post

  5. #5
    I am sure you are doing this but have you checked the actual expeditions tab? (I think it has a ship wheel) on the upper left side of your screen? Also, my quest did not pop up until I had 500 Artisans. I then received a newspaper flash about the (spoiler) missing. I then got a quest pop up from Archibold to visit him at his island. Once I spoke to him then the actual expedition quest popped up.
    Share this post

  6. #6
    Hey,

    I started the same mission after the new update and have the same issue. The captain's expedition message doesn't pop up. Mission task is ''complete expedition new world expedition'', but when I open the quest details there are no expedition icons on world map. I have more than 500 artisians and finished father's diary quest a while ago. Plus there is no expedition tab on the left side bar.

    Not sure how to proceed, or if this is a newer bug since the update.
    Share this post

  7. #7
    Same issue, find any fix or did you just have to quit your campaign?
    Share this post

  8. #8
    I just continue with playing and waiting for a fix...
    Share this post

  9. #9
    I have stopped playing the game for now. Will not be buying the dlc any time soon.
    Share this post

  10. #10
    Ubi-Woofer's Avatar Ubisoft Support Staff
    Join Date
    Aug 2019
    Posts
    284
    Originally Posted by Hertz_01 Go to original post
    Hi Mod_Freeway,

    Thanks for your input, am I missing something really obvious, I can't seem to do your suggestions?

    If I press the top section of the quest "Mission to a new world" it opens up details about the quest. If I press the lower section of the quest "Mission to a new world" it opens up the world map, nothing about starting expeditions shows up.
    I'm sorry to hear that you're unable to proceed with the quest, Hertz_01. Are you able to provide me with images / a short video clip showing that the option is unavailable to you to proceed? Could you also let me know if you remember anything unusual happening prior to this quest being due to begin?

    Originally Posted by TheNobruSamurai Go to original post
    Same issue, find any fix or did you just have to quit your campaign?
    Thanks for letting us know that you're also affected, TheNobruSamurai. As above, could you provide any images / video clips of the issue?

    Originally Posted by Filitus Go to original post
    I just continue with playing and waiting for a fix...
    Filitus, if you could also provide any images / video clips of the issue if you are also experiencing this, please do provide them here for us to take a look into.
    Share this post