1. #1

    [PERMANENT FIX] Stutter Issue Fix For NVIDEA Users!

    Hello fellow Assassin's,

    Here is the solution for those of you who have been pulling hairs on the stuttering happening (every 3 seconds) & stuttering in general.

    After a whole month of crucial testing, I have finally figured out the only solution (even after Patch 4 & the Driver Version 347.09).

    NOTE THAT THIS FIX IS ONLY FOR NVIDEA USERS

    You will need to remove Assassin's Creed Unity from your NVidea Control Panel. To do so, follow these simple steps.

    1. Download NVIDEA Inspector (you can google it for other links if you don't have winzip or winrar).:
    http://www.guru3d.com/files-details/...-download.html

    2. Run the nvidiaInspector.exe & you will see a box pop up showing your Graphics Card information.

    3. Click on the "Tools" icon circled in red.


    4. Click on the drop down arrow/menu & then select the Assassin's Creed: Unity Profile. (Mine doesn't show because I already removed it). Press the X button to remove the selected profile, then click on "Apply Changes". Then exit.


    5. You can select any setting in-game & you will be fine. Co-Op stuttering should stop as well. Restart your computer for extra measure.

    If anyone has any issues, please post your system specifications in your comment, so others including me can help you out faster!
    Don't forget to submit tickets to Ubisoft Customer Service for other issues with AC Unity.
     4 people found this helpful
    Share this post

  2. #2

    While everyone seem to have big troubles even after PAtch 4 i can admit that i have with this workaround a decent improvement stuttering is gone more fps and no crahes for now.

    Probably Ubi developers will be able to improve the performance further in the future patches.

    Thanks for this tip brother
    Share this post

  3. #3
    THANK YOU!!! I really hope Ubisoft/Nvidia fixes this issue without having to do this though...
    Share this post

  4. #4
    Omg this works wtf!!!
    Share this post

  5. #5
    Hm might have to try this, any way to back up the changes?
    Share this post

  6. #6

    Not working for me help please

    did nothing for me still fps drops every 5 secs or less
    I have AMD PHENOM II x6 3.4
    9 gb ram
    Nvidia geforce gtx 660 2 gb vram

    something else?
    Thanks
    Share this post

  7. #7
    Originally Posted by Faramird Go to original post
    did nothing for me still fps drops every 5 secs or less
    I have AMD PHENOM II x6 3.4
    9 gb ram
    Nvidia geforce gtx 660 2 gb vram

    something else?
    Thanks
    What settings do you currently have set in-game?
    Share this post

  8. #8
    Originally Posted by holydruid Go to original post
    Hm might have to try this, any way to back up the changes?
    You don't have to back anything up. If you want to re-add AC Unity back to your NVidea Control Panel, you can at any time.
    Share this post

  9. #9

    Settings are

    Originally Posted by Shaftex Go to original post
    What settings do you currently have set in-game?
    I tryed High - medium - and low ( on the graphics settings that changes all the advance settings ). non of them changed the fps drops the same drops

    i can say you my settings are all in high or normal aa x2 and vsync yes , bloom yes

    I may be wrong.

    Thanks
    Share this post

  10. #10
    Update: this doesn't completely remove the stutter but it does greatly reduce it, the game is somewhat more playable now.
    Share this post

Page 1 of 9 123 ... Last ►►