🛈 Announcement
Greetings! Ubisoft General forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #321
    I'm in too! (for now)
    Share this post

  2. #322
    I lost my old phone with the Google Auth, changed my pass, and now I can't login both in app and website to change account details(primarily take off 2FA)

    What happened to the good old Security questions???.I also lost my back-up keys. SO I guess that's on me. Please advise.
    Share this post

  3. #323


    What does this fancy "visual issues caused by Degradation" or something actually mean?
    Share this post

  4. #324

    Is only a certain area affected by this "glitch"

    I have a friend from Eastern CAD that is able to log in but , I Eastern States can not.

    Also i bought a booster and was wondering if i was gonna be refunded to reimbursed for the booster i bought?
    Share this post

  5. #325
    Its ok for me now, all fixed <3 thnx ubi for the quick fix <3
    Share this post

  6. #326
    none of that worked for me. however, on the upside. they might have fixed it as of 4:31AM UTC+8
    Share this post

  7. #327
    open a ticket with ubisoft support.
    Share this post

  8. #328

    I can't access my account on the desktop app !!!

    I can't access my account on the desktop app !!! I can't play...
    ''Your account has been accessed from another location. This may...''

    Share this post

  9. #329


    Try linking UPLAY to steam as a game.. then open UPLAY in steam and log in. Least I got in to play
    Share this post

  10. #330
    I did the following and it was successful for me.
    I logged in to my account via the browser and changed the password there.
    Then I tried the login over the client again. That did not work.
    So I logged in again via the browser and changed the password again in my old password.
    Then I tried it again in the client but also that did not work.
    So I just started a game (in my case Assassin's Creed Odyssey) via the desktop shortcut.
    You have to sign up again.
    No catch on remember me.
    That worked for me.

    I hope it works for you too.
    Share this post