1. #1

    Unable to Play game for 3 weeks (I want a refund)

    Look, I have had a ticket (08693111) open for 3 weeks now. I have reached out on these forums and Twitter, but still have not received a response from anyone. I am totally fed up.

    I paid $108 dollars for this game and I have been unable to use the product for 3 weeks. I demand a refund.
     4 people found this helpful
    Share this post

  2. #2
    same story here but after i try those things no crash or ctd appeared

    https://forums.ubi.com/showthread.ph...highlight=DX12

    https://forums.ubi.com/showthread.ph...pril-17th-2019
     1 people found this helpful
    Share this post

  3. #3
    Thank you for the reply. I have tried the first one already. Tried the second thread but still no good. I still can't get past the loading screen without it crashing.
     1 people found this helpful
    Share this post

  4. #4
    how many gpu's do u have in ur system because all ubisoft games working the best with 1 gpu

    have u updated ur drivers installed directx
    latest updates from windows
    Share this post

  5. #5
    Lens00140's Avatar Senior Member
    Join Date
    Feb 2019
    Location
    Straya
    Posts
    2,094
    Originally Posted by DarthDobber54 Go to original post
    Look, I have had a ticket (08693111) open for 3 weeks now. I have reached out on these forums and Twitter, but still have not received a response from anyone. I am totally fed up.

    I paid $108 dollars for this game and I have been unable to use the product for 3 weeks. I demand a refund.
    3 weeks is not acceptable and I'm sure the replies from support are not helping.

    What are you running on your end DarthDobber54, AMD or Intel for the processor?, Nvidia or Radeon for the GPU?

    Also if you cannot get the game to start after using ISLC with the correct setting plus the page file settings on Windows 10, are you running on Windows 7?... if so you may need to look at the DPI settings and the refresh rates/settings on your monitor plus the Windows sound settings

    https://imgur.com/a/RFY9dO1

    Btw this game is killing SSD's so make sure to keep backups
    Share this post

  6. #6
    I have one GPU.

    Also, it may be helpful to point out that as part of my troubleshooting, I have reinstalled Windows from scratch. I installed Windows, updated all drivers, updated the system and installed Uplay. Then I installed TD2 but I was still unable to load the game.

    Here are my specs:

    i5-6600k @ 3.5 GHz
    48 GB RAM
    Nvidia Geforce 1080
    One SSD and One HDD - C:\ drive is SSD and that is where the game is installed.
    Windows 10
    Share this post

  7. #7
    Thank you so much for the reply!

    I changed my sound settings but still no good. I just don't understand. I don't have anything strange going on in my setup and I have disabled every single background service so it shouldn't be interference. Plus, I reinstalled Windows and it still wouldn't work.

    I'm just exhausted by this whole process and what makes it even worse is that Ubisoft support hasn't even attempted to help me. There is literally 1 reply from them 3 weeks ago where they asked me to disable background processes, empty out my temp folder, and a few other things. I did everything they asked and sent them screen caps to prove I did exactly as I was asked. Since then, it has only been me responding to the ticket asking for updates.

    I literally have no idea if they are even working on this issue at all. A little communication could have gone a long way.
     1 people found this helpful
    Share this post

  8. #8
    Originally Posted by Lens00140 Go to original post
    Btw this game is killing SSD's so make sure to keep backups

    How so? if true with proof I have no problem binning this piece of ****.

    Devs have shown they are incompetent at best and lazy idiots at worst. When one of your "troubleshooting" steps is "reinstall windows" you can go F yourself as a game company.
     4 people found this helpful
    Share this post

  9. #9
    Ubi-Johan's Avatar Community Developer
    Join Date
    Oct 2016
    Location
    Base of Operations
    Posts
    2,596
    Hello there,

    We are sorry to hear that. Could you please try adding -DX12 on command line in Uplay, as this might resolve the issue for you.

    For further assistance on how to set launch arguments on Uplay: https://support.ubi.com/en-gb/faqs/2...nch-arguments/

    Please let us know if it works, or if the issue still persists.

    Cheers,
    Share this post

  10. #10
    Can you provide a link to some other options for the game launch arguments and what they do?
     1 people found this helpful
    Share this post