1. #1

    Can't install or update the game

    So I went to fire the game up yesterday and found I needed to update. I downloaded the 15Gb update only to have it stop at 99%, about 100Mb short of complete. I got the following error message...

    "Download Failed. Please check that you have an active internet connection and sufficient space on your hard drive, the click retry to start the download again, or try again later."

    I know for a fact that my internet connection or my HDD space is not an issue. I have since re-tried the download 3 times with the same result. I've uninstalled and re-installed the entire game both on the same and a different hard drive. I get the same error. I've uninstalled Uplay, downloaded the client again and reinstalled, but still no luck.

    I've created a ticket but still haven't heard anything and unfortunately, I honestly don't expect to.

    I've run out of things to try. I'd appreciate any advice.
     1 people found this helpful
    Share this post

  2. #2
    This same thing has just happened to me as well

    54.18gb out of 54.19gb giving me that same exact message

    l also created a ticket to get no reply
    Share this post

  3. #3
    +1.

    When you look inside the game folder, what seems to be the entire file structure for the game is sitting inside a subfolder, unpacked, ready to go. But because Uplay doesn't recognise the game as installed, it won't allow me to verify the game files.

    I've found a number historic posts on reddit, Ubisoft forums, etc. that suggest trying to uninstall/reinstall both the game and Uplay, change install drives, re-download and limit transfer speeds, copy the contents of the download folder to the game directory, reinstall Easy Anti-Cheat, and so on...

    I've done all of the above, and probably attempted to download the game ten times now. Nothing seems to have made any difference.

    Another user at my address is also experiencing the same issue - which makes me think the issue is either a broken patch/installer or a problem with their Content Delivery Network/caching. Either way, I've given up at this point as it appears nothing can be done as an End User to resolve the issue.

    This is why I hate the fact that my game library is being fragmented by every man and his dog releasing exclusives on their less-than-capable Steam alternative.

    Ubisoft - please either find a permanent fix to these sorts of issues, or stop releasing games exclusively on Uplay. Your customers deserve better.
     1 people found this helpful
    Share this post

  4. #4
    Update: I have been able to resolve the issue.

    Download a free VPN, and change your location to somewhere in the USA if you are not located there already (if you are, change to Europe I suppose? ).

    If you were logged in, Uplay will probably log you out due to the change in IP address. Sign back in to your account, and expect 'Security notification regarding your Ubisoft Account' email warning you of a login to your account from an unexpected IP.

    Once you've successfully signed in from the 'USA', retry your Division 2 download, which should download ~15Mb worth of files, and then complete nearly immediately. I was then able to disconnect from the VPN, and launch the game.

    After connecting to the game servers, there was a small in-game patch which downloaded from within the loading animations, which then required the game to be relaunched. After lauching for the second time, the game successfully reached the main menu.

    This re-inforces my suspicions that the fault is most likely due to caching/CDN issue.

    PSA: if you haven't already, enable 2FA on your account. Due to their lack of ability to respond to basic support tickets, I wouldn't expect much in the way of support from Ubisoft if your account is ever comprised
    Share this post