🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Co-op not working

    Hello there,

    Me and my boyfriend bought Anno 2070 Complete Edition. But we can't invite each other as there is every time a connexion failure.
    Please help.
    Share this post

  2. #2
    Ubi-Redbeard's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017

    Apologies for the delay in receiving a reply.

    Can you confirm if you managed to resolve your co-op issue?
    Share this post

  3. #3
    My girlfriend and I are also experiencing the same issue. We try to invite each other into a game, she will get my invite, but I never receive hers. When she receives my invite, she isn't loaded into the game and all I see is the "waiting for players" spinning loader animation.

    I've run through firewall settings and can't see anything obviously incorrectly set. Does anyone have any ideas?
    Share this post

  4. #4
    Same story here, can see eachother in the contact list, but invitations don't come through.

    Sometimes they do come through, and if we click accept, nothing happens.

    If game is set to public, the game is visible but cannot join.

    Share this post

  5. #5
    I made sure the firewall allows Anno 2070, did all the port forwarding, and ended up using a VPN and it worked. Then it didn't let me save my files, so I manually had to set save files to non-read only. Now I can save, but now the game doesn't recognize the save files. In the whole process, we started a new game 3 times and wasted our whole weekend starting over and over again.
    Share this post

  6. #6
    I have exactly the same issue. I tried FW/AV shutdown but nothing works. We used to play Anno 1404 (GoG version) and that works well. But I spent several hours trying to connect 2 PCs that are in one network. Accounts are visible in contact list but it looks like only one can be fully online - can send messages send invites but the other PC sees it but cannot reply nor accept invitation. I managed to somehow connect once but I was unable to repeat it so far.
    Share this post