🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Anno 2070 won't let me play...because some problem with Deep Ocean addon


    First I want to say that I love this game, but I don't have time to play very frequently. Last time I played was 6 months ago (uplay tells me). I just installed it on my laptop and I'd like to play now, but I've been working trying and reading in the past few hours and no chance. I keep bumping into various problems and this is getting me upset.
    Why can't you guys fix your problems and not make us fix them for you so that we can play and enjoy something we payed for and that should be delivered to us in one piece.

    Here is my problem. When I start the game I get a message that tells I have activated the addon, but the contents have to be downloaded and that in order to do this I have to close the game and the updater will start. Click restart to begin the process. My only option is Reboot, so I click it and nothing happens.
    If I click on DLC in the uplay menu it tells me that I can Buy it for 10EUR. But I have already bought it once for 20 or 25 I don't remember it was some time ago and I can send you a copy of the transaction if I must. This is unacceptable service quality and you can't expect me to buy other games from you if I get this kind of treatment.

    In response to other threads that I've read. I have already tried with the autopatcher, I renamed it to autopatcher2 and it just did nothing, I tried with the offlinepatcher, but that won't work either. If anyone knows of another way to make it work please tell. My free time today has already been spent trying to fix this game for uplay, but I'm still hoping I can log in later today or if not at least I can fix it so I can play later in time.
     2 people found this helpful
    Share this post

  2. #2
    I have just had this same problem, I downloaded the 2.00 patch and ran it on its own. Sorted the problem for me.
    Share this post

  3. #3
    I had the same problem when I bought anno 2070 on friday
    I found a forum answer to someone with similar problems from Ubi-Kay that i tried and it worked

    this is the 2.0 patch link Ubi-Kay posted in that thread:

    you are probably gonna get a popup error when starting it that says:
    support/manual/eula.rtf was not found
    just press ok and then ok again on the next window that pops up
    the error is what i believe caused because the AutoPatcher can't find the End User License Agreement file

    you may also have to re-enter you license key so have that ready aswell

    this is the prosess to do it in:
    1. Navigate to your install location of Anno 2070 (Mine was at: C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\ANNO 2070)
    2. Locate the file titled "AutoPatcher.exe" (depending on your Windows configuration, you may not see the .exe file extension. In these cases the file will just be named "Autopatcher").
    3. Right-Click this file and select "Rename".
    4. Change the name of this file to something like"AutoPatcherBackup.exe"
    5. Paste the Downoladed 2.0. AutoPatcher and rename it to "AutoPatcher.exe" and then rightclick it and run it as Administrator (this is where you may get an error message)
    5. Reopen the UPlay PC Client and relauch Anno 2070. (this is where you may be asked to re-enter your licence key for the game)
    6. When Anno 2070 launches, you will recieve a message: "You have successfully activated the addon. Before the addon can be used​​​, the updater must still download the necessary data." Here you do as always and click the "Reboot" button.
    7. Anno 2070 will reboot and correctly apply the needed updates.
    8. Start Anno 2070 again and you should be able to play again.
     10 people found this helpful
    Share this post

  4. #4
    Well i remember when i bought dlc had the same issue, that was some time ago and its still not fixed, with really shows how much UBISOFT cares about customers.

    Anyway while this solution works, I have other issue... I dont have cdkey anymore and now I have two lovely options, first is to buy game and DLC again so i can enter cdkeys or just to crack game and play offline, because while game is in my librery, i can download it and press play it just lunch then says it have to install DLC and then updater just stop working, if i change autopatcher then it ask me for cdkey.

    If it was STEAM game, even if such thing would happen i could always check my cdkey and then enter it, ofc that whole situation is absurd in it self since if you have game in your library in first place that means you bought the game so why asking for cdkey?

    Well wanted to play it a bit again before new ANNO but after what i see i wounder if i should buy it in first place since it will aslo required UPLAY and so far my experiece with it is very negative and I dont see UBISOFT change its policy anytime soon, if you make DRM like UPLAY at lest make sure it works and its not hutring customers.

    All i have to say is, its really sad when its easier to download game from torrents then crack it, rather then actualy buy a game and then find a way to make it work, this should never be the case... (this is about patcher issue not cdkey, thats completly diffrent problem)

    Thats my small rant about how i cant play game i bought becase UPLAY is such a awsome thing
     1 people found this helpful
    Share this post

  5. #5
    Try to see if it is in your account information on your UPlay PC Client

    Next to your username there should be an arrow.
    Click that and then account information,
    there Anno 2070 should be listed and have a show key button that lets you see it
    Share this post

  6. #6
    I did check that out allready, i have cdkey for Heros of Might and Magic but as for Anno goes i have this info: "Uplay does not store key information for this conten".
    Share this post

  7. #7
    same issue, just endless loop, autopatcher does not download update
    Share this post

  8. #8
    I tried the above with the offline patcher 2.0 thingy. but when i do it it says

    - Anno2070 is not installed
    - Anno 2070 is already up to date
    - Anno 2070 installatin is corrupted. incase reinstall.

    I got the complete edition from steam. havnt played a single second of the game :/
     3 people found this helpful
    Share this post

  9. #9
    I'm having the same exact problem as MihaiulRau... I contacted Uplay support a week ago, but haven't heard anything back from them...
    I tried the updater 2.0 thingy, but I had to supply it with a cd-key I don't have anymore. I recently moved, and I threw away the physical copy I had of Anno 2070, since I had already used the cd-key in Uplay, I thought I didn't need it anymore...

    I'm also having the same problem as Daskis... When I go to check my cd-keys in Uplay I can see the cd-key's for all my other games, except for Anno 2070. I get the same "Uplay does not store key information for this content." as Daskis got.

    For all my other games Uplay games I can see the key... Even the ones that was a retail game, and I just used the cd-key in Uplay...

    I'm so tired of fighting with this game to get it to work, and SO demotivated... I have spent countless hours trouble shooting this game... I don't really like to complain about stuff, but this deserves it! I have been a PC Gamer for over 25 years now, and this is probably the first time I haven't been able to fix the problem....

    I was going to play this before the next release, as I haven't had the time to play Anno 2070 yet... I was gonna buy the next Anno, I was gonna buy AC:Syndicate, Rainbow Six: Siege and The Division... But this was my last straw... this is where I draw the line in the sand... NO MORE UBISOFT GAMES.... and that's kinda both mine and their loss... I love many of the ubisoft games, they just wrap the games in bad DRM that ruins it for honest customers........
    Share this post

  10. #10
    Hello guys,
    I had the same problem today.
    Short story - I've played Anno 2070 about a year ago, but when I heard about new Anno game I decided to refresh my memory. I have run the game through Uplay launcher and then i got info about need of game restart to run DLC properly. OK - I've done it, but autopatcher command line disappeard fast and done nothing... After do this few times I decided to completelly uninstall and install game again through Uplay. But this didn't help me...
    On Steam forum I have found this file:
    but launcher wanted a cd-key from me which I don't have anymore (WTF? Game is added to my library so why should I keep it?). After using it in many combinations (renaming files etc.) I tried to repair my files many times and finally it started with all bought DLCs unlocked.
    I don't know what happened and why this stupid problem appearings, but maybe my way of fixing will help you.
     3 people found this helpful
    Share this post

Page 1 of 8 123 ... Last ►►