1. #1

    Emergency Evacuation can't go on

    Hi there,

    I've completed the campaing in normal mode then moved on with expert. I'm on Emergency Evacuation where i should escord a few Isabel's ships to my main island La Isla. However, they are on the southmost point of the map (not far from the pirate island) and almost out of the map. I can still get there but nothing happens when i do so. Be it with my main ship, a great armada, even closing/reloading the game, saving/loading again, leaving the new world and getting back...nothing seems to do.
    I should also mention that i got to escort a few ships from her central base to there. I don't remember if they were the same ships (since it's the second time i'm doing the campaign, i didn't bother to much with reading the lines) but it looks like so.

    Also, as a side not, during the first chapter where we investigate what happened to our father, the part where we need to track down and kil la boat was pretty bugged. I tracked the boat and then killed the flamethrower one that popped up. But for some reason, i've loaded another save shortly after. Then when i went to follow the boat, it immediately disappeared and i could already go to the point where i have to kill the boat...and then it was stuck in the mountain. Fixed it by trying several times with various ships//layoutds and reloading the game.

    Hope somebody can help me get past this, expert mode campaing is not really something i want to do again xD
    Share this post

  2. #2
    I have the exact same problem, any solutions?
    Share this post

  3. #3
    Found a gif that perfectly pictures the issue, thanks to user @syfer3k

    Share this post

  4. #4
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Hey Benji_tshi,

    Thank you for the report!

    I have passed this along to the dev team.
    Share this post

  5. #5
    All of my quests broke once my 2 frigates arrived in the New World for the "Emergency Evacuation" quest. Can't continue the game, and every time I load an earlier save it just bugs out again at the same point.
    Share this post

  6. #6
    Me too!
    Share this post

  7. #7
    I had this problem too. Quite by accident, I had a schooner that was doing my trading for me and I just happen to time it where the schooner was selling weapons, and all the rest of my ships were there at the same time and poof it kicked in.
    Share this post

  8. #8
    Hi all,

    I am having the exact same issue as well (ship that I should escort move to the south point of the map and stay there). Maybe as an additional information: A few hours earlier I lost my Colony in the new would (La Isla) to an AI opponent and had to take it back first. Maybe this confused the covoy target destination finding process...
    Share this post

  9. #9
    True, i totally forgot but that happened to me. AI took my island minutes after i landed. I took the exact same one back (as well as every other one, you know, payback !) but that might mess up the quests
    Share this post

  10. #10
    I am in the same boat too (no pun intended).

    On this quest, all 3 ships to be escorted moved straight to the bottom of map. They went out of play area for a little bit and turned around and just sat in the corner.
    When I first moved into the New World, I had also lost the La Isla island as I was at war with Beryl O'Hara. She just happened to have a fleet next to it when it was handed to me. Couldn't do anything to stop that and eventually took it back.

    Another thing of note is that any ships I've commanded to escort the 3 ships randomly end up going back down to those ships - even if I've ordered them to go elsewhere. Say if I leave my ships idle up north on the map, they'll head down there again without my control. Usually getting bombarded by Jean La Fortune if I don't have a cease fire with him on their way down.

    So now the campaign is effectively stuck.
    Share this post