1. #1

    A comprehensive list of bugs in Assassin's Crees III Remastered.

    I must preface this by saying I am loving the remastered version and can't believe how well the gameplay ideas have aged but there is one thing that is hampering my enjoyment and it's the technical problems. The remaster should have never been released in this state. It's way buggier than the original version and I'm not even sure how that is even possible when the hardware is much more advanced now.

    I'm aware this belongs in the technical forum but seeing as most people don't actually browse the threads there I wanted to start in the general forums first to compile more findings. I'm also aware some of these problems have been mentioned by others and will be updating this list if I encounter any more. Please feel free to add your findings and platform.

    On PS4:

    • Music for the viewpoint synchronisation does not stop.
    • Can't defend convoy sometimes because it doesn't appear on the map.
    • Connor clipping through the floor.
    • Quest steps remaining on screen long after you've finished them.
    • Various instances where Connor gets stuck in a climb loop and can't move.
    • Animals disappearing after you kill them so can't skin.
    • Environmental objects not spawning - some are mission related.
    • Some frame rate drops.
    • Frontier map saying "shop not visted" yet the shop has been visited. This may be a visual bug but if not then this could potentially affect the Coureur des Bois trophy.
    • Trigger sensitivity issues with sprinting - discussed further in this thread.
    • Game doesn't save notoriety after quitting i.e. goes back to incognito (although this may be deliberate).
    • 1 invisible almanac in New York. Shows icon on the map but doesn't show the actual page in the game so Connor is chasing thin air.
    • When fast travelling to a captured fort the cut scene for the yanks shoving Brits out plays again...
    • The game has decided to give Connor a haircut long before he actually does it himself. See image below:

      This bug was in the original version as well. Unacceptable.
    • Sometimes Connor doesn't pull out his weapon in combat.
    • Sometimes guards will not fight you even if you deliberately antagonise them.

    Spoiler:  Show
    When Prudence goes into labour Warren doesn't move when you go get him.

    Some of these bugs are offset by simply reloading checkpoint or restarting the game but most aren't.

     7 people found this helpful
    Share this post

  2. #2
    @Ubisoft, I have to reiterate: we are customers, not QA/QC, or Beta-testers, don't ask for videos, or screenshots as proof, don't ask people to go through useless FAQs and "trouble-shooting" threads. The lack of care for the game, the lack of customer-appreciation, the lack of QA/QC and testing of this game are quite apparent by now.

    "Bis repetita non placent", but it seems necessary to do, as otherwise nobody ever learns, and please don't be an apologist, you have paid money for the game, Season Pass or not, you can expect a fully working product, you don't have to just accept and move on, and hope that maybe just maybe next time it will be better; it won't, because this way you give them reason to believe that you are willing accept low quality without complaint.

    "To the customers belongs the power, not to the shareholders"
     5 people found this helpful
    Share this post

  3. #3
    I am on PS4 as well and have experienced most of the same issues and noticed several more. None of them are serious, but they are all annoying.

    • Sometimes when Connor pulls out his pistol, his upper body gets stuck in a certain position while automatically reloading. His legs move normally (which looks absolutely ridiculous when he starts free running). Eventually he resumes reloading and his body moves normally.

    • In the Boston underground, in the areas with enemies, only one will appear at first, though I hear two voices. After I kill the first enemy, two more spawn and trigger open conflict. This has happened on multiple occasions.

    • A custom marker appears automatically on the Homestead every time I reenter the area. It was like that in the original as well.

    • The cutscene after sequence 5 mission 5
      Spoiler:  Show
      (where Kanen’tó:kon arrives at the Homestead to warn Conner about William Johnson)
      had just a white screen. The audio played, but there was no visual. Once I regained control of Conner, the HUD appeared but the white screen persisted. I could see a slightly darker outline of Conner and the Manor. I was able to reset it with a fast travel. That’s a pretty important part of the story and I’m upset that I missed it.

    • Almost all the caves in the Frontier are impossible to navigate without both turning up the game brightness to 10 and using eagle vision. The free-running areas in the Boston and New York undergrounds (where you have to drop the lantern) is the same.

    • In the shop, the Scottish Flintlock Pistol (obtainable through the Ubisoft Club) looks the same as the English Flintlock Pistol. The model on Conner’s hip is unique though and looks like how it should.

    • I have also experienced a rather weird issue where the NPC audio plays backward. I have already posted about it here (since it also occurs in Liberation) in the hopes that it will be addressed. This occurs every time I begin Sequence 8. I hear it even in the first cutscene. All other audio, like characters and the environment—sans NPCs—is normal.
     1 people found this helpful
    Share this post

  4. #4
    UbiCosmos's Avatar Community Representative
    Join Date
    Oct 2018
    Hey there,

    Thank you for compiling together this very comprehensive list. I am going to move this to the Support Team, so they can take a further look into these issues.
    Share this post

  5. #5
    Even more with spoilerish videos for sequence 10 and 11

    • My fully upgraded double barrel gun sometimes doesn't allow 4 rounds, only 3 or 2.
    • Sometimes my gun disappears from my equipped tools.
    • It's raining indoors:

    • Showing as notorious even when not in restricted areas yet guards don't investigate and there are no noteriety reducing vendors...
    • Had to do the Rope Beater brawler challenge twice before getting the next mission step to find the Merchant in New York even though I beat the Rope Beater the first time....
    • In the underground tunnels there was a guard stuck in the wall and as I was in open combat with him so couldn't pick up the torch to continue. Had to run away in the dark and become incognito.
    • "View hint" stays on long after you've already solved the mason puzzle in the underground tunnels.
    • Assassination contract glitched inside a building in the Frontier. I remember this bug, they never fixed it!!! I had to use a trip mine just outside the house to kill him, injuring myself in the process.
    • I don't even know what this:

    • Some of the naval missions towards the end have optional objectives that completely disappear from the menu even when you press options.
    • In the final confrontation with Nicholas Biddle the countdown timer for sinking the the men of war doesn't start...
    • The lip syncing in sequence 11 for Charles Lee is completely off:

    • Connor's new hair cut doesn't show in the in-game engine until after the first cut scene with the new hair cut. At least not with Shay's outfit equipped anyway.
    • Camera sometimes gets stuck after a significant animation.
    • You can't untrack other quests when in a main mission causing screen clutter over the main mission objectives.

    Possibly more to follow...
    Share this post

  6. #6
    Bump, cause this is a VERY thorough list of stuff that NEEDS an update.
    Share this post

  7. #7
    Also, don't know if a bug or not, but when you kill enemies during winter there's no blood splatter on the ground like in the original version.
    Share this post

  8. #8
    Literally just encountered this; in the Homestead horses constantly get stuck on nothing while you're riding around.
    Share this post

  9. #9
    Yo, me again. Not necessarily a bug , but AC3 R's subtitles are WAY too big on normal. Especially compared to those in the original version.
    Share this post

  10. #10
    Share this post