1. #1

    Armor On Kill ---DOES NOT WORK---

    I have stacked several gear mods with "Armor On Kill" and I DO NOT receive any armor when I kill an enemy. It DOES NOT show my correct Armor On Kill stat on the Stat Page, only shows 0 no matter how many I have equipped. I have tested it in combat to disprove the "it's just a Stat Page glitch" theory. It DOES NOT WORK. Just wanted to clear this up since I've seen several threads saying the same thing. Not sure why this isn't a more widespread issue. Maybe it doesn't happen to everyone. Definitely something for the devs to look into please. Other than that, I have had very, very few issues. Great game guys.
    PS4 Pro
    Share this post

  2. #2
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019
    Posts
    2,870
    Hey, thank you for this report.

    Would it be possible to provide a small video with an explanation of this issue? We'd like to review it to make sure there is no confusion and it would help our devs reproduce it.

    I'm glad to hear you've been enjoying the game overall!
    Share this post

  3. #3

    Screenshots/Video

    Yes, I can do that. I'll try to provide as much info as I can in the video. Might not be perfect as I don't have a capture card, but I'll do my best lol. Sorry if this is a dumb question but I don't see any upload button. How can I post the video here?
    Share this post

  4. #4
    Originally Posted by Ubi-Raziel Go to original post
    Hey, thank you for this report.

    Would it be possible to provide a small video with an explanation of this issue? We'd like to review it to make sure there is no confusion and it would help our devs reproduce it.

    I'm glad to hear you've been enjoying the game overall!
    I went ahead and recorded the issue. I'm not sure if one should have an attribute for Armor on kill, as I do not have one.
    Share this post

  5. #5
    Yeah that's pretty much it. Add "Armor on kill" mod to a gear piece, check stats page, says 0, tested it, didn't gain any armor on kill. That's what I'm experiencing.

    For future reference... did you just copy/paste the link to that video into the message? That's the only way to show screenshots/video?
    Share this post

  6. #6
    Originally Posted by SwampLifeUF Go to original post
    Yeah that's pretty much it. Add "Armor on kill" mod to a gear piece, check stats page, says 0, tested it, didn't gain any armor on kill. That's what I'm experiencing.

    For future reference... did you just copy/paste the link to that video into the message? That's the only way to show screenshots/video?
    Embedded from YouTube. I think you can do Vimeo too? Don't know about screenshots.
    Share this post

  7. #7
    10 4. Thanks
    Share this post

  8. #8
    Same problem here as well. Never noticed it because of the swarming and very little time to react to it to dead. Just cleared the Hotel without losing a good chunk of armor, every kill made did not add to the missing segments. At this rate with all the bugs and glitches, they'll have to give us another 49 gig patch.

    Do the devs not play their own game thoroughly before testing it? It's starting to seem like it.
    Share this post

  9. #9
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019
    Posts
    2,870
    Hello everyone.

    First of all, thank you RoughRafa for providing a video and explaining to SwampLifeUF how to imbed video

    The video provided looks to be a display issue alone. If you look closely, you did actually gain armour for your kill, however you gained about 3,000 out of a total 145,103, so it was hard to notice.

    Can anyone else confirm if you're definitely not receiving armour, and if you can provide a video? If not, I can just report the stat not showing correctly.

    Thanks!
    Share this post

  10. #10
    Agent_Putt's Avatar Member
    Join Date
    Feb 2016
    Location
    UK
    Posts
    241
    Armor on kill on mods are pointless. The values are so small they’re not worth the investment
    Share this post