1. #1

    After 1.7 Game stuck in Russian, was previously English

    Title says it all, anyone else having this issue? It's quite frustrating, something so random and buggy happening.

    Bought my game through UPlay. Changing preferred language in UPlay game settings does nothing. Reinstalling does nothing. Game has always been fully in English until now, been playing since launch. Cant figure out what to do.
     1 people found this helpful
    Share this post

  2. #2
    I need an update on this. My $100 “gold edition” game that has worked since launch is now suddenly unplayable, completely stuck in Russian regardless of changing language settings via Uplay or reinstalling.
    Share this post

  3. #3
    try deleting Tom Clancy's The Division 2 in \Documents\My Games
    it will reset all custom settings
    Share this post

  4. #4
    I appreciate the suggestion, however it didn’t work. It’s acting like it’s permanently stuck in Russian and won’t change to any other languages regardless or changing the Uplay settings, or completely reinstalling.
    Share this post

  5. #5
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,046
    Hello bucknasty_! I am sorry to hear about your language issue. When you reinstalled the game, did you have the option to select English? You should have the option in-game settings as well for English. Did you try verifying your game files?
    Share this post

  6. #6
    Of course I have done these things, multiple times. Of course it has English selected when I reinstall, my whole point is that NOTHING seems to make a difference.
    Share this post

  7. #7
    I have deleted all language packs except English, and it's still in Russian. When doing a fresh install IN ENGLISH, NOT selecting "install additional languages" still ends up in Russian.
    Share this post

  8. #8

    Language change

    Hey I had the same issue and I was able to figure it out. You have to change it in the in game settings like I did. Just go over to the tab that looks like a circle with the jagged edges which is the settings tab. Then scroll down to the second to last option which would be the language change, you’ll want to change the very first option as the second uptown is already I engligh. To find English just scroll to the left for the first option.....
    Share this post

  9. #9
    anyone ever find a fix for this? i did all above and nothing. i even found ingame setting and it shows in english but everything is russian...
    Share this post

  10. #10

    I also have the same issue

    All my games are automatically russian and I tried everything to make them English and it didn't work, even if I change game language in settings, it doesn't change anything, in some games that option is not even present, so I have bought some games and didn't bother installing them, when I did (after steam refund time was expired) it was too late for a refund. contacted support, but they didn't help at all, sent another message about another game, and didn't even get a response back. I guess I will make sure to stop buying ubisoft games starting today, since today I just installed another game and its also locked to Russian. If support doesn't even try to fix the problem for the consumers then there is no need to support this company.
    Share this post

  11. #11
    Ubi-Redbeard's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    6,424
    @Hipopotalamus - please refrain from reopening closed threads.

    As for your issue, do you have a support case open with us already?
    Share this post