1. #11
    Ubi-Shikallum's Avatar Community Staff
    Join Date
    Jul 2017
    Posts
    3,800
    Hey again,

    Sorry for the miscommunication on our end in that ticket, I think the agent was a bit confused and provided the wrong information.

    With your Shadow service your clock speed is 2.50ghz, is there any way to make the CPU run faster, the minimum clock speed needed for the game is 3.1GHZ

    As I said in another thread, it's difficult to troubleshoot with the Shadow service
    Share this post

  2. #12
    I don't think clock speed is an issue. Nor is it an issue troubleshooting with the Shadow service.

    According to your official minimum requirements page: https://support.ubi.com/en-US/faqs/0...astered-AC3RM/

    You're looking for a 2400S at 3.1 except the 2400S also only comes in 2.5, it is only the 2400 without an S that comes in 3.1.

    For the sake of comparison I added both and then compared them to the Xeon. https://www.cpubenchmark.net/compare...793vs794vs2584

    The Xeon is ahead of the 2400S in single-core performance and only slightly behind the 2400.

    But the Xeon has way more cores than either of them and in terms of overall performance the Xeon is a significantly better CPU than either the 2400 or 2400S. With the Xeon being released September 2014 and the i5 2400's being released January 2011, that's another point in doubt that the Xeon is somehow inferior.

    And a final point, I'm assuming that the requirements for the Liberation: Remastered are the same because they are not listed separately. I am able to load that game just fine in my shadow. It's only AC3: Remastered that I cannot.

    Again, I'm going to have to stress that "troubleshooting" is extremely unlikely as a solution. This needs to be escalated as an actual bug report so it can be patched and fixed.
     4 people found this helpful
    Share this post

  3. #13
    Support replied to my ticket by linking me to this:
    https://support.ubi.com/en-GB/faqs/000025947


    After that I read that instruction AGAIN and performed a clean boot of Windows 10, here's what to do:
    https://support.microsoft.com/en-gb/...oot-in-windows
    Than I finally succeeded in launching AC3.

    After all I found the trouble. It's Bluetooth. Plugging out the dongle or switching it off in Windows is the solution for me, AC3 doesn't crash anymore.

    I don't know how can it be related to each other, that's why I recommend to perform a clean boot, there may be another service causing troubles.

    (sorry for bad English)
    Share this post

  4. #14
    Glad it worked for you. A clean boot was already tried several times as well. Still not a fix for everyone. My computer doesn't even have bluetooth.
    Share this post

  5. #15
    Ubi-TheBerry's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    2,289
    Originally Posted by ZenUp2 Go to original post
    I'm having a similar problem.]

    I just bought "AC III Remastered", which includes "LIberation Remastered"
    AC III works just fine, but whent I try to start "Liberation", it struggles to load, then either freezes on the load screen, or crashes completely.
    Sometimes I get an error message "Ubisoft has lost connection", even though I'm still logged in/connected to Uplay.
    Anyone else having this problem, or know the fix?

    Thanks,

    RF
    Hey there,

    Sorry for the delay and to hear you're having issues launching Liberation.

    Please try the steps in our PC troubleshooting guide as well as our Uplay PC Connectivity Guide and let us know if there are any changes!
    Share this post

  6. #16
    Same with me! Liberation works fine but AC III won't launch no matter how many times I press play. I have the same issue with Unity. Other AC games like AC Origins and Odyssey launch just fine. I'm very disappointed that this thread was posted last year and this issue is still not patched in 2020. I can't launch from Steam or Ubisoft Connect.
    Share this post

  7. #17
    Ubi-Litten's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    1,803
    Sorry to hear you are also experiencing this issue, if you are still unable to access this after completing the steps provided in the post above could you please provide your system reports (as advised in our troubleshooting guide) or contact us directly through our "Live Chat", Twitter or Facebook.
    Share this post

  8. #18
    Ubi-Baron's Avatar Ubisoft Support Staff EMEA
    Join Date
    Aug 2017
    Posts
    7,547
    Hi toxawo92372,

    Are you having an issue running the game?
    Share this post