1. #1

    Purchased Gold edition - Can't play Open Beta

    I purchased the gold edition, I wanted to buy from Ubi, but was directed to Epic. So I have purchased and played the private beta.

    Received no option to pre-download the open beta, but today when I was supposed to play the open beta I was asked to connect my Epic account with my UPlay account. That was complete then and I received errors about the linked accounts. I rebooted my PC and started again, re-downloaded my Epic Installer and My Uplay installer.

    Now I launch from the game from epic with a "UPLAY LOGIN REQUIRED" notice and am asked to enter an activation code. I was given no activation code from Epic for the open beta.


    What do I do now?
    Share this post

  2. #2
    I got the exact same issue as this.
    Share this post

  3. #3
    just play it via uplay, no purchacse nessisary
    Share this post

  4. #4
    Originally Posted by CloudWOmega Go to original post
    just play it via uplay, no purchacse nessisary
    Easier said than done
    Share this post

  5. #5
    Originally Posted by Dryaxx Go to original post
    Easier said than done
    Try restarting Uplay
    Share this post

  6. #6
    Originally Posted by CloudWOmega Go to original post
    Try restarting Uplay
    Sadly restarting does not resolve the issue.
     1 people found this helpful
    Share this post

  7. #7
    Originally Posted by Dryaxx Go to original post
    Sadly restarting does not resolve the issue.
    what about reinstalling Uplay/the game?
    Share this post

  8. #8
    Originally Posted by CloudWOmega Go to original post
    what about reinstalling Uplay/the game?
    I somehow managed to find the dumbest solution. Seems that since I have played the closed beta, that somehow was seen as the Open Beta client.
    Went to the game directory folder and launched the game exe from there. Uplay then updated the Closed Beta to an Open Beta version.

    Strange, strange bug.
    Share this post

  9. #9
    OK I have tried all of these. As I uninstalled the private beta I can't start the game from that executable, I have reinstalled uplay, and there is no link to download the open beta, This is quite frustrating.
    Share this post

  10. #10
    Originally Posted by WalkofShame Go to original post
    OK I have tried all of these. As I uninstalled the private beta I can't start the game from that executable, I have reinstalled uplay, and there is no link to download the open beta, This is quite frustrating.
    are you missing this?
     1 people found this helpful
    Share this post