1. #1
    aessae's Avatar Junior Member
    Join Date
    Dec 2017
    Posts
    10

    Progress not reset from closed beta and related(?) problems

    Logged in and noticed I still had my rider level, ingame currency, track records and gear customisation from the closed beta - and someone stole my pants when I wasn't looking.
    I believe this messed with the game start, I just got a bunch of unlock messages ("WOO CHALLENGES" etc) and got thrown to the world map. The University opened up after I ran one beginner map, but I can't use the Rhino since I guess I technically haven't leveled up to lvl4 yet.
    Also the gamepad prompts are wrong or missing most of the time for some reason. Wat do?
    Helpful screenshot: https://puu.sh/CPvUW/9de5be9c74.jpg
     3 people found this helpful
    Share this post

  2. #2
    Same issue. Can't progress because I am level 34 and the rhino doesn't unlock until level 4. Trying to find the save file, but deleting the ones in My Documents\Trials Rising and My Documents\Trials World Tour didn't work.
    Share this post

  3. #3
    aessae's Avatar Junior Member
    Join Date
    Dec 2017
    Posts
    10
    Looks like Uplay's cloud save feature was responsible for the progress not getting reset, thanks to JettY on the discord for the fix. Disabled cloud save sync from uplay's settings and then renamed the folder under Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegames (and Documents\Trials Rising\SavedGames just in case).
     6 people found this helpful
    Share this post

  4. #4
    nandesz.00's Avatar Junior Member
    Join Date
    Oct 2016
    Location
    Hungary
    Posts
    5
    Thanks, that works indeed.
    Share this post

  5. #5
    Problem solved
    Share this post

  6. #6
    Cheers aessae, that's sorted it.
    Share this post

  7. #7
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Posts
    7,058
    Hey aessae,

    Thank you for sharing this with the community!
    Share this post

  8. #8
    s0ad667's Avatar Senior Member
    Join Date
    Oct 2011
    Posts
    1,071
    Glad to find a quick fix about this, just had this issue. Now game won't connect to the servers though, guess i will wait for an hour or so and hope to see my progress wiped.
    Share this post

  9. #9
    TeriXeri's Avatar Senior Member
    Join Date
    Mar 2014
    Posts
    1,163
    Deleting the correct save game from the Ubisoft Game Launcher/Savegames folder fixed it for me.

    It was some numbered folder, so picked the one with the timestamp right after closing Rising.
     1 people found this helpful
    Share this post

  10. #10
    Dosent work for me or my frieind who was in a private/ beta (Not the closed beta a beta before that or a test)
    Not working for me.
    Share this post