1. #1

    An unexpected DirectX error occurred (DXGI)

    https://imgur.com/a/E1zl9ED

    Crashing every so often (5-10 minutes?) with the same error
    Share this post

  2. #2
    Bug: Direct command queue error / DX12 errors / DirectX
    Original Reporter: Dr4g0n 36
    Thread: https://forums.ubi.com/showthread.ph...nd-queue-error
    Status: Reported to Devs
    Actions taken to Fix: Try changing settings from the config file: Documents/ANNO 1800 Closed Beta/config/engine.cfg , Change "DeviceType": "DX12" to "DeviceType": "DX11". Save file and resart uplay and ANNO
    - setting game to DX12 in graphics settings the game is unable to load and give a DX Error such as "failed to create direct command queue / Error code 1211"
    Share this post

  3. #3
    I will try, changing that, but I have little hope.
    In game, its set to DX11 but the ini file says DX12.

    In DX11 mode, the game crashes upon loading, while in DX12 mode it works for about 10 minutes.


    Unrelated to the game, but posting to these forums is a real hassle. I have to click "submit reply" maybe 10 times before it actually submits. It treats all clicks as "Preview post" instead. I have have clicked through probably 80 captchas, and all they do is preview the post.
    Share this post

  4. #4
    I see the same error & behavior as LordBones42.

    Additional I see a spike in GPU 3D Usage in the Task-Manager short before the game hungs itself whilst CPU access is going down. I saw also a spike in drive utilization short before game hungs.

    Just in case this helps. I tried it two times, I saw the same behavior two times with DirectX 12 whilst I don't come that far with DirectX 11
    Share this post

  5. #5
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,025
    Hi LordBones42! Can you clarify what your PC specs are? The issue with DX12 has been reported to the Anno team.

    @superdummy2001 What are your PC specs as well?
    Share this post

  6. #6
    The game seems to spike to 100% GPU usage, then crash.

    Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
    Language: Swedish (Regional Setting: Swedish)
    Motherboard: Z97X-Gaming 3
    Processor: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
    Memory: 16384MB RAM
    Page File: 12972MB used, 6272MB available
    GPU: NVIDIA GeForce GTX 1080
    2560 x 1440(p)

    (I can only seem to post on these forums once per day, and that is only through spamming the SUBMIT REPLY button until the page hangs. Otherwise I am stuck in an endless loop of Captchas, that only preview my post)
    Share this post

  7. #7
    Bump

    I liked what little I got to play of the beta, but I can't play when it crashes willynilly.
    Share this post

  8. #8
    Ubi-Gumdrops's Avatar Ubisoft Support Staff
    Join Date
    May 2018
    Posts
    2,374
    Thanks for the update LordBones42, this issue has been documented with the development team.
    Share this post