1. #51
    Its fixed!!!
    Share this post

  2. #52
    i guess with the new “secrets of Greece” episode they added on it came with a patch. Because I been dealing with this since December and just now it said to quit to the home screen for new downloable content and when I went back on the alpha lion was alive and I finished the quests. So stoked
    Share this post

  3. #53
    Is it fixed? *** yeah!!!
    Share this post

  4. #54
    no!!!! alpha lion still dead. it's not fixed. T__T
    Share this post

  5. #55

    Dead Lion Club

    We're coming up on the half-year point since release and this issue has not yet been resolved.
    Share this post

  6. #56
    Fate of The Atlantis DLC is coming near, but we alpha lion club member’s problem hasn’t been solved. Ubisoft should be shame.
    Share this post

  7. #57
    Hi guys. Patch 1.2.0 has come. Have you checked whether it’s fixed or not?
    Share this post

  8. #58
    When i logged in, it was auto put into my inventory. The quest was stuck since like November when i did it, it only took four months!
    Share this post

  9. #59
    Hey guys -- sorry I havent checked this post in so long.

    Looking very forward to the new expansion -- so the most important question. Has this been completely fixed???

    I see mixed responses as of late on the thread.
    Share this post

  10. #60

    The mission isn’t able to be started glitch

    [QUOTE=Ubi-Gumdrops;13881644]Hi there arathorn1210, I'm very sorry you're encountering this issue. Rest assured the development team are actively working on a resolution for this.

    There is an ongoing glitch that doesnt allow me to start the mission: Lore of the Sphinx at all.... is this an common glitch or is this very rare? I tried restarting the game twice and no luck. I beat all the mythical creatures instead of the sphinx. Is there anything you can do to help?
    Share this post

Page 6 of 6 ◄◄  First ... 456