1. #1

    Gotta Go Fast (Travel) game breaking bug

    So I've been playing the game for a few hours and I get the "Gotta Go Fast (Travel)" quest. I activated the main street fast travel location, but the quest wouldnt complete. So I went around and activated every other one I could find, but it still didn't work. I even went ahead and did every other quest I could but now Im stuck because the story won't progress.
     2 people found this helpful
    Share this post

  2. #2

    Same Issue

    Hello Ubisoft

    I have the exact same problem. I've activated 5 stations now and been trying to use the Main Street fast travel post, but the quest won't complete.
    Share this post

  3. #3
    ubi--unicorn's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    9,511
    Hi there. Thank you for the reports. I'll pass this along. Thanks again!
    Share this post

  4. #4
    Same problem here! I bought the game and I can not play! Thanks, Ubisoft. Plataform: PS4
    Share this post

  5. #5
    Jip I have the same problem. Has this been sorted yet. Do we have an ETA on a patch or fix
    Share this post

  6. #6
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,450
    Hi Bl0odStone! Can you clarify what platform you are playing the game on?
    Share this post

  7. #7

    I have the same problem...

    I have the same problem and would like to know the fix without having to start over...
    Share this post

  8. #8
    **** i just bought this game. And stuck in the sam problem. When will you ****ing fix it!?
    Share this post

  9. #9
    Originally Posted by personarss Go to original post
    **** i just bought this game. And stuck in the sam problem. When will you ****ing fix it!?
    I have the same problem.

    My platform is on PC.

    Do you have this bug since a long time ago. Would you fix it ?
    Share this post

  10. #10
    UbiMorning's Avatar Community Representative
    Join Date
    Sep 2017
    Posts
    15,450
    Hey csilvak. I responded to you here.
    Share this post