1. #1

    Game on Steam, nothing happens when I click Play


    I cannot launch Trials Fusion anymore. I'm on Windows 10 Home edition 64 bits. Everything is up to date, from Windows to my Nvidia graphic drivers.

    When I click "Play", I can see myself going to "In-Game" status on Steam for about 5*10 seconds, and then nothing, my status goes back to "Online" but absoluetly nothing happened on the screen. The game doesn't launch. It doesn't even attempt to start UPlay.

    I tried to launch UPlay by hand, still nothing. Tried to launch the game from UPlay, nothing. Reinstalled the game, nothing, reinstalled UPlay, nothing. Set the exe to execute in admin mode, nothing. Set the comnpatibility mode to various verisons of Windows, nothing.

    I'm out of idea and I cannot play a game I purchased which is not good. Especially when the only games making issues on my computer are always Ubisoft games and seem somehow related to that wonky crappy UPlay.

    Any advice?

    Share this post

  2. #2
    Ubi-MrDrPink's Avatar Community Manager
    Join Date
    Aug 2017
    Twitter: @MrDrPink
    Hi there ZupaleX,

    I'm sorry to hear you ran into some trouble trying to access Trials Fusion. If you're still encountering this issue, please can you open a Support ticket with our team?
    Share this post

  3. #3
    I did but none of the solutions offered help unfortunately. I've been told to contact Microsoft about a "recurring issue that [the support team] spotted after thorough analysis of the log files". Though I've been told that after almost 2 weeks of back and forth with support and somehow all my other games work perfectly fine so to me it sounds like "we have no idea so we will just blame somebody else to get rid of the ticket".
    Share this post